Hmmm most strange, using same version of compiler as yours
2.047

I have attached the file for you to try, not sure if it makes
a difference that I am running on 64 bit win7?

I am not after help, just to confirm there maybe a bug with
either ubyte or == ?

Cheers
begin 644 main.d
M:6UP;W)T('-T9"YS=&1I;RP@<W1D+F-S=')E86TL('-T9"YC+G1I;64L('-T
M9"YC+G-T9&QI8CL-"@T*=F]I9"!M86EN*"D-"GL-"@EI;6UU=&%B;&4...@=6)Y
M=&4@;&EM:70@/2`R,#L-"@D-"@ES<F%N9"AT:6UE*&YU;&PI*3L-"@EU:6YT
M(&-H;W-E;B`](#...@*r!r86yd*"D@)2!L:6UI=#L-"@D-"@EW<FET96QN*")4
M:&ES(&ES(&$...@9w5e<W-I;F<@9V%M92(I.PT*"7=R:71E;&XH(DD@:&%V92!C
M:&]s...@82!n=6ub97(@8F5T=V5E;B`Q(&%N9"`R,"(-"@D@("`@("`@("(@
M=VAI8V@@>6]U(&UU<w...@9w5e<W,B*3L-"@D-"@EU8GET92!G=65S<R`](#`[
M#0H)#0H)9F]R*'5B>71E(&EC;W5N="`](#,[(&EC;W5N="`^(#`[("TM:6-O
M=6YT*0T*"7L-"@D)=W)I=&5F;&XH(EEO=2!H879E("5S('1R)7,@;&5F="XB
M+"!I8V]U;G0L(&EC;W5N="`]/2`Q(#\@(GDB(#H@(FEE<R(I.PT*"0EW<FET
m...@b96yt97(@82!G=65S<SH@(BD[("\O('!R;VUP="!F;W(@82!G=65S<PT*
M"0es8v%...@b)60B+"`F9W5E<W,I.R`O+R!296%D(&$...@9w5e<W,-"@D)#0H)
M"2\O(&-H96-K(&EF(&=U97-S(&-O<G)E8W0-"@D):68H9W5E<W,@/3...@8vao
M<V5N*0T*"0E[#0H)"0EW<FET969L;b...@b7&Y9;w...@9w5e<W-E9"!I="$B*3L-
M"@D)"7)E='5R;c...@#0h)"7T-"@D)#0H)"2\O($-H96-K(&9O<B!A;B!I;G9A
M;&ED(&=U97-S#0H)"6EF*&=U97-S(#P@,2!\?"!G=65S<R`^(#(P*0T*"0E[
M#0H)"0EW<FET96QN*"))('-A:6...@8f5t=v5e;B`Q(&%N9"`R,"X@(BD[#0H)
M"7T-"@D)96QS90T*"0E[#0H)"0EW<FET969L;b...@b4v]r<GDN("5S(&ES('=R
M;VYG+B(L(&=U97-S*3L-"@D)?0T*"7T-"@EW<FET969L;b...@b>6]U(&AA=F4@
M:&%D('1H<F5E('1R:65S(&%N9"!F86EL960N(%1H92!N=6UB97(@=V%S("5S
<(b...@8vao<V5N*3L-"@ED:6xn9v5...@i.pt*?0``
`
end

Reply via email to