http://d.puremagic.com/issues/show_bug.cgi?id=3092


Don <clugd...@yahoo.com.au> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |clugd...@yahoo.com.au


--- Comment #9 from Don <clugd...@yahoo.com.au> 2010-10-19 13:32:36 PDT ---
(In reply to comment #8)
> I have now fixed the bug, it's a trivial 7 line patch which teaches
> TypeSArray::resolve(...) to recognize if it's indexing a type element. Without
> the patch, TypeSArray::resolve(...) will create a 1-element-slice when 
> indexing
> a type in a tuple. This fixes the bug described in this issue.
> 
> This patch does not fix the pragma(msg, "values:    ", values); bugs, which is
> caused by another bug I described in a previous comment. That one would also 
> be
> easy to fix, it's only a formatting bug, I'm just not sure how a proper patch
> for that would look like.
> 
> I also tested dmd rev 714 (that one in branch dmd1.x) and my patched version 
> of
> it in dstress. No improvements, regressions or changes were introduced. I then
> created a testcase that can be added to the dstress/compile/t directory, which
> passes with my patch applied, but fails in dmd rev 714.

Sounds as though you have been running dstress. Could you please post the
results somewhere? I would be very interested to see how many dstress bugs are
still unfixed in the most recent DMD version.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to