http://d.puremagic.com/issues/show_bug.cgi?id=5083

           Summary: module object cannot read file 'object.d'
           Product: D
           Version: D2
          Platform: x86
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: DMD
        AssignedTo: nob...@puremagic.com
        ReportedBy: andy.el...@paradise.net.nz


--- Comment #0 from Andy Elvey <andy.el...@paradise.net.nz> 2010-10-20 03:29:56 
PDT ---
This problem has been reported before, but I am reporting it again - it
*really* needs to be fixed. I'm using Ubuntu 10.04.   

I originally mentioned this problem on the D mailing-list here - 
http://www.mail-archive.com/digitalmars-d-le...@puremagic.com/msg07626.html

I've tried installing D three ways - 
* Using the .deb file from Digital Mars. This seemed to install fine, but I got
the "cannot read file object.d" when I tried to compile a simple program. 

* Running "linux.mak" in the /src directory. Same error. 

* Using the ddebber tool. Seemed to install fine, but the same error again. 

The problem seems to be with the dmd.conf file, but the end-result is that the
install does not work "out-of-the-box". Knowing where the problem seems to be
is one thing - fixing it is quite another.  

An aside - it would be a *great deal of help* if the install process created a
log that you could refer to afterwards. 

I'm not a complete newbie. I've compiled and installed many applications in my
years on Linux, but few have given me as many problems as D. Even GHC (Haskell) 
which is a BIG application, installs and runs flawlessly. 

This problem is disappointing. I still believe that D is a great language, but
problems like this *really* need to be fixed for it to gain more users.     
- Andy

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to