http://d.puremagic.com/issues/show_bug.cgi?id=6024



--- Comment #8 from Jonathan M Davis <jmdavisp...@gmx.com> 2011-05-17 13:12:57 
PDT ---
Well, all I have to go on is the documentation, and it says Win2K pro. I have
no idea if any of them work prior to that, and if they don't, then there's no
way to get that code to work on a version of Windows that old. Still, I find it
to be astonishing that we're at all concerned with anything prior to XP at this
point. If there are developers who want to make it so that some code checks the
version of Windows that it's on and adjusts what it's doing accordingly, then
that's fine with me, but if it were my choice, I'd say that we should just say
that we're not going to support anything older than XP (or _maybe_ Win2K) and
be done with it. Heck, I'd _love_ to be able to require Vista or newer given
some of the system calls that they added, but that would be totally
unreasonable, since XP is still heavily used. But I wouldn't expect anything
older than that to be much used at this point, and particularly for D2, which
is a newer language and arguably not even production-ready yet, I think that it
would be perfectly reasonable to say that it's not supported on OSes which are
very much out-of-date.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to