http://d.puremagic.com/issues/show_bug.cgi?id=6353

           Summary: No stacktraces on x86_64
           Product: D
           Version: unspecified
          Platform: x86_64
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: druntime
        AssignedTo: nob...@puremagic.com
        ReportedBy: jmdavisp...@gmx.com


--- Comment #0 from Jonathan M Davis <jmdavisp...@gmx.com> 2011-07-20 00:46:20 
PDT ---
This program

void main()
{
    assert(0);
}

prints this on x86_64:

core.exception.AssertError@w(3): Assertion failure
----------------
----------------

_All_ stack traces look like that on x86_64. For this one, if I were to compile
with -m32, I'd get this:

core.exception.AssertError@w(3): Assertion failure
----------------
./w(onAssertError+0x2e) [0x806111e]
./w(_d_assertm+0x16) [0x805f096]
./w() [0x805ca76]
./w(_Dmain+0xd) [0x805ca61]
./w(_D2rt6dmain24mainUiPPaZi7runMainMFZv+0x1a) [0x805f53e]
./w(_D2rt6dmain24mainUiPPaZi7tryExecMFMDFZvZv+0x20) [0x805f1d8]
./w(_D2rt6dmain24mainUiPPaZi6runAllMFZv+0x32) [0x805f582]
./w(_D2rt6dmain24mainUiPPaZi7tryExecMFMDFZvZv+0x20) [0x805f1d8]
./w(main+0x94) [0x805f184]
/usr/lib32/libc.so.6(__libc_start_main+0xf3) [0xf75aa233]
----------------

So, this is purely a 64-bit issue. But the lack of stacktraces on x86_64 is a
definite impedement to debugging, and it really needs to get fixed.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to