--- Comment #3 from David Simcha <> 2011-08-30 08:27:11 PDT ---
I would argue that it should be allowed because there's no ambiguity, for two

1.  That's the way it already works and changing it would break code and
probably TDPL.

2.  If we're going to make things more verbose, more annoying for generic code
and different from what people from a C++ or Java background expect, we'd
better have a compelling reason.  Your example in Bug 6579 doesn't cut it.  The
root of the problem is that reset() is a poorly chosen name, not that allowing
static methods to be called via an instance is a bad feature.

Configure issuemail:
------- You are receiving this mail because: -------

Reply via email to