http://d.puremagic.com/issues/show_bug.cgi?id=6748

           Summary: Library specifications are not up to version.
           Product: D
           Version: D2
          Platform: Other
        OS/Version: All
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: websites
        AssignedTo: nob...@puremagic.com
        ReportedBy: tbo...@gmail.com


--- Comment #0 from Timofei Bolshakov <tbo...@gmail.com> 2011-09-30 11:37:56 
PDT ---
My code was developed on dmd version 2.052 and now I am trying to update my
code according to requirements from dmd 2.055. It generates multiple
deprecation warnings, like:

Notice: As of Phobos 2.054, std.string.zfill has been scheduled for deprecation
in January 2012. Please use std.string.rightJustify with a fillChar of '0'
instead.

But the rightJustify is not in the
http://www.digitalmars.com/d/2.0/phobos/std_string.html

I do not think documentation was changed since 2.053 (Last update Wed May 18
11:23:50 2011) - so, it is hard or impossible to follow such a Notices.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to