http://d.puremagic.com/issues/show_bug.cgi?id=8429

           Summary: [2.060 beta] 'version' rejected inside 'static if's
           Product: D
           Version: unspecified
          Platform: All
        OS/Version: All
            Status: NEW
          Keywords: rejects-valid
          Severity: regression
          Priority: P2
         Component: DMD
        AssignedTo: nob...@puremagic.com
        ReportedBy: cbkbbej...@mailinator.com


--- Comment #0 from Nick Sabalausky <cbkbbej...@mailinator.com> 2012-07-24 
20:14:42 PDT ---
static if(true)
    version = Foo;
static if(true)
    version(Foo) {}

Worked in 2.059, fails to compile on 2.060 beta:

test.d(2): Error: version Foo defined after use

(Note: If you comment out line #3, it still fails, and that's issue #7386, but
that's *not* a regression)

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------

Reply via email to