Summary: Different naming of member base/next in TypeInfo_Const
                    in object_.d and object.di
           Product: D
           Version: D2
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: druntime

--- Comment #0 from Rainer Schuetze <> 2012-09-14 01:02:12 
PDT ---
In object_.d, the name of the modified type in TypeInfo_Const is called "base",
while in object.di, the declaration looks like this:

class TypeInfo_Const : TypeInfo
    TypeInfo next;

This forces you to use different namings depending on whether you compile with
druntime or something else. I recommend naming it "base" as all other TypeInfo
declarations do.

TypeInfo_Const in object.di even shadows the next() property of TypeInfo that
returns something else. Unfortunately the next field already seems to be used
in phobos, so it has to be changed there aswell.

Configure issuemail:
------- You are receiving this mail because: -------

Reply via email to