On Saturday, 19 July 2014 at 15:04:33 UTC, Jacob Carlborg wrote:

Ideally I would like that the native type is used, that's what I've done in the OS X port. But if the existing code uses "int /*long*/" then I would say it's acceptable to use "ptrdiff_t". Perhaps we want to come up with a new name?

What do you mean by "native type"? I thought the only native types in D were `size_t` and `ptrdiff_t`. What's the actual syntax you use in the OSX port?


If you're looking for alternative names for `size_t` and `ptrdiff_t` how about:

alias native_int = ptrdiff_t;
alias native_uint = size_t;

Mike

Reply via email to