On Monday, 12 February 2018 at 15:51:58 UTC, Marc wrote:
the warning is:
Non-selected package lnk is available with version ~>0.2.1.
What does it mean by *Non-selected* package lnk is available?
from what I could tell from the page, it's highest version.
But I've tried low versions anyway to see if it Works 0.2.0,
0.1.1 etc and none did.
I noticied I put "lnk": "~>0.2.1" on cachedUpgrades section so
I moved there to just created "dependencies" section then the
dub's error is gone but it fail to find the lnk library:
Error: module lnk is in file 'lnk.d' which cannot be read
The package I'm trying to include is:
DUB version 1.5.0, built on Sep 1 2017
DMD32 D Compiler v2.076.0
What am I missing? I'm new to dub so everything is new to me,
1) What's your dub.sdl / dub.json?
2) Did you try dub upgrade?