On Sun, Jun 02, 2019 at 02:32:16PM +0000, Paul Backus via Digitalmars-d-learn 
> If std.v2 ever materializes, we'll have an opportunity to fix
> papercuts like this. Until then, my preferred workaround is to use a
> renaming import:
> import std.traits: hasNontrivialCopy = hasElaborateCopyConstructor;

Couldn't we just rename hasElaborateCopyConstructor to hasNontrivialCopy
and leave a deprecated alias from the former to the latter? (Or perhaps
without the deprecation, but the documentation would use the new name
and hopefully new code would, too.)


Unix was not designed to stop people from doing stupid things, because that 
would also stop them from doing clever things. -- Doug Gwyn

Reply via email to