On 2019-06-17 20:53:28 +0000, aliak said:
Less typing for one. Otherwise you'd have to write:
auto observer = observerObject!int.observerObject(TestObserver());
Since code is many times more read than written I will never understand
why the syntax is polluted to save some keystrokes, making it much
harded for others who don't have 800 pages special cases in their mind
to read the code.
One explicit alias or so would be OK too for cases where such a
declaration is needed more than once.
But anyway, thanks.
Robert M. Münch
smarter | better | faster