On Tue, 14 Jul 2009 12:37:47 -0400, Bill Baxter <[email protected]> wrote:

On Tue, Jul 14, 2009 at 7:26 AM, Leandro Lucarella<[email protected]> wrote:
Kagamin, el  9 de julio a las 09:46 me escribiste:
DiP2 is here. Check it.

http://www.prowiki.org/wiki4d/wiki.cgi?DiPs
http://www.prowiki.org/wiki4d/wiki.cgi?DiP2

ps code markup is not very nice.

It would be very nice if you include at least the abstract in the mail, so
it's easier to discuss the DIP here.

And as bearophile pointed, the DIP is missing the author. I think a DIP
can't be taken very seriously without an author. I think a DIP author
should be committed to maintain the DIP (this doesn't mean that other
people can't update it) and do the requested changes to make the DIP move
forward to its acceptance.

As for the DIP itself, I didn't used the const system in D2 yet, so
I can't give a good opinion, but I think that adding a new kind of
pseudo-constness can be a little bloat. Of course, having to copy the same
code 3 times is much worse, so if nobody has a better solution for the
problem, I guess I can live with it =)

I have to say I read the previous proposals when they were proposed
here on the newsgroup, but when I saw the DIP just using a new keyword
"vconst" instead of "inout" it looked soooooo much more readable to
me.  Might just be me, but I think my brain had a hard time convincing
my eyes that inout had anything to with const.

Yeah, when I used inout, I was sort of trying to cut off some of the "oh no, not another keyword" objections. I tried my *hardest* to explicitly say that the keyword doesn't matter, the proposal still works with any keyword name, but it just doesn't work. People latch onto the keyword like flies on a bikeshed covered with, um.. stuff.

I also had another alterior motive in that certain people who seemed to be influential with Walter liked the idea of using inout.

I really couldn't care less what the keyword is, because no matter what it ends up being, it is much easier to deal with than writing N copies of a function, especially when the code is identical.

-Steve

Reply via email to