On Wednesday, 12 October 2016 at 23:59:15 UTC, Stefan Koch wrote:
On Wednesday, 12 October 2016 at 23:47:45 UTC, Andrei Alexandrescu wrote:

I think we should define two aliases "likely" and "unlikely" with default implementations:

bool likely(bool b) { return b; }
bool unlikely(bool b) { return b; }

They'd go in druntime. Then implementers can hook them into their intrinsics.



I was about to suggest the same.
I can prepare a PR.

We should probably introduce a new module for stuff like this.
object.d is already filled with too much unrelated things.

Reply via email to