On 06/12/2010 19:00, Jonathan M Davis wrote:
On Monday, December 06, 2010 05:41:42 Steven Schveighoffer wrote:
On Mon, 06 Dec 2010 04:44:07 -0500, spir<[email protected]> wrote:
On Mon, 6 Dec 2010 00:31:41 -0800
Jonathan M Davis<[email protected]> wrote:
toString() (or writeFrom() or whatever
it's going to become)
guess it was writeTo() ;-) but "writeFrom" is nice as well, we should
find some useful use for it
It was proposed as writeTo, but I'm not opposed to a different name.
I have no problem with writeTo(). I just couldn't remember what it was and
didn't want to take the time to look it up, and the name isn't as obvious as
toString(), since it's not a standard name which exists in other languages, and
it isn't actually returning anything. Whether it's to or from would depend on
how you look at it - to the given delegate or from the object. But writeTo() is
fine. Once it's used, it'll be remembered.
I don't think it's entirely fine. It should at least have
"string"/"String" somewhere in the name. (I mentioned this on the other
original thread, although late in time)
--
Bruno Medeiros - Software Engineer