Thank you Nick (and everyone else who attempted to help). At the end of the day I ended up blowing away my load again and going back to 14.04 and all is happy again. I am guessing something was going on with my local IT's sudo wrapper that effects a 16.04 pybombs install process but not 14.04, but I am not sure. An attempted load on a 16.04 machine with and without being under IT's control would probably be needed to get to the bottom of this!

Thanks everyone for the time though!

On 10/13/2016 01:49 PM, Nicholas McCarthy wrote:
(However, I think there's a lot of upside to installing on a vanilla OS for comparison, replicating your error on your IT-polluted OS, and forcing IT to fix the problems they're imposing on you.)

Nick M.

On Thu, Oct 13, 2016 at 1:42 PM Nicholas McCarthy < <>> wrote:

    You need to remove all versions of pip you previously installed
    and truly start fresh with the curl command.

    I recommend starting with a completely fresh install and never
    typing "sudo."  (This is assuming you DO have a reasonable python

    Until you can run commands like pip install pybombs and pybombs
    recipes add without getting permissions problems, your system is
    really too broken to deal with.

    If you're happy with adding the recipes using sudo and you can
    install gnuradio using sudo from your current state, then just do

    Nick M.

    On Thu, Oct 13, 2016 at 12:48 PM Jason Matusiak
    <>> wrote:

        Nick, A little more information.

        I try to do the next step (add recipes) and I get the following:
        jmat@jmat:~$ pybombs recipes add gr-recipes
        bash: /usr/local/bin/pybombs: Permission denied

        Looking at that binary, it has permissions 700.  I chmod it to
        755 and rerun and get:
        jmat@jmat:~$ pybombs recipes add gr-recipes

        Traceback (most recent call last):
        File "/usr/local/bin/pybombs", line 11, in <module>
            load_entry_point('PyBOMBS==2.2.0', 'console_scripts',
        File "build/bdist.linux-x86_64/egg/pkg_resources/",
        line 567, in load_entry_point
        "build/bdist.linux-x86_64/egg/pkg_resources/", line
        2603, in load_entry_point

        ImportError: Entry point ('console_scripts', 'pybombs') not found

        If I run the command with sudo, it seems to work, but I assume
        that that is not a good practice, right?


        On 10/13/2016 12:34 PM, Jason Matusiak wrote:

        I spoke with IT and I was mistaken on the "script" version of
        sudo.  What is really going on is that we use centrify's dzdo
        as sudo.  They just made a wrapper so that users can call
        sudo like usual and dzdo gets called under the hood.  So the
        sudo //should// be pretty normal.

        I went to the look you sent me and ran the command: curl | python.  I get the
        following error back:
        jmat@jmat:~$ curl | python
% Total % Received % Xferd Average Speed Time Time Time Current Dload Upload Total Spent Left Speed
        100 1488k  100 1488k    0     0  6323k      0 --:--:--
        --:--:-- --:--:-- 6336k
        Requirement already up-to-date: pip in
        Collecting wheel
          Downloading wheel-0.29.0-py2.py3-none-any.whl (66kB)
            100% |████████████████████████████████| 71kB 6.0MB/s
        Installing collected packages: wheel
        Traceback (most recent call last):
          File "/tmp/tmpZg40zI/", line 215,
        in main
            status =, args)
          File "/tmp/tmpZg40zI/", line
        317, in run
          File "/tmp/tmpZg40zI/", line 742,
        in install
          File "/tmp/tmpZg40zI/", line
        831, in install
            self.move_wheel_files(self.source_dir, root=root,
          File "/tmp/tmpZg40zI/", line
        1032, in move_wheel_files
          File "/tmp/tmpZg40zI/", line 346, in
            clobber(source, lib_dir, True)
          File "/tmp/tmpZg40zI/", line 317, in
          File "/tmp/tmpZg40zI/", line
        83, in ensure_dir
          File "/usr/lib/python2.7/", line 157, in makedirs
            mkdir(name, mode)
        OSError: [Errno 13] Permission denied:

        Trying it with sudo returns the same errors.  My solution to
        get it to install was to sudo su -, and install it from
        there.  Supposedly it has something to do with sudo forking
        the command back to the user or something (this level of
        admining is over my head; but I wonder if something different
        is going on in 16.04 that was previously allowed in 14.04 for
        me).  I then exited out of sudo su, and ran sudo pip install
        pybombs and that worked.  Now I am going to continue down the
        path and see if I can get further along.

        Sorry for all the issues, but thanks for piping up.

        On 10/13/2016 12:17 PM, Nicholas McCarthy wrote:
        Hey Jason,

        That's interesting... I was expecting it to prove your user
        saw a different version of setuptools than running sudo.  I
        think there's still evidence that may be the case, but I'm
        not sure.

        I think your best bet for building gnuradio on your
        non-vanilla machine is to start from scratch assuming you do
        not have sudo privileges.

        Assuming you have a reasonable python installed, you should
        be able to install pip using this.

        Then pip install pybombs

        Then use pybombs

        However, if your ultimate goal is to work with your IT to
        get to the root of your bizzaro OS problems, then I would
        1. Do a pybombs install using your initial set of commands
        on a truly vanilla ubuntu (to prove that it works and to
        give your IT something to compare with the broken system).
        2. Follow these same steps on your non-vanilla ubuntu to
        reproduce your error.
        3. Dump the problem on your IT telling them to solve
        whatever permissions and system path problems they need to
        solve to make system 2 behave like system 1.

        Nick M.

        On Thu, Oct 13, 2016 at 11:24 AM Jason Matusiak
        <>> wrote:


            Thank you for the info.  I've uninstalled pybombs
            everywhere, so I should be "clean" again.

            I tried running your two easy_install commands and got
            an unexpected result:
            jmat@jmat:~/Downloads$ easy_install --version
            usage: easy_install [options] requirement_or_url ...
               or: easy_install --help

            error: invalid command 'easy_install'
            jmat@jmat:~/Downloads$ sudo easy_install --version
            setuptools 28.3.0 from
            /usr/local/lib/python2.7/dist-packages (Python 2.7)

            I sort of figured that the non-sudo version would give
            some sort of result based on your email.  Does this tell
            us something?



            On 10/12/2016 02:58 PM, Nicholas McCarthy wrote:
            So.... If I look at sys.path in python, I do see
            (and I didn't do anything special to make this happen.)

            Also, which pybombs points to

            And my install location for pybombs is

            From the standpoint of a fresh install (which you
            certainly no longer have), I think the problem comes in
            when you fail to have permissions on the pybombs bin...
            I suspect that's something to do with your weird sudo
            script and not pip or pybombs, but I'm not sure.

            If you could get back to the state you were in after
            your initial attempt to install, I'd like to know the
            value of your sys.path in python.

            Right now, you have a frankenbuild for pybombs thanks
            to running sudo with the --user flag... I would
            uninstall that, for sure and get to where you have no
            pybombs installed anywhere.

            So... as for why you can't pip install pybombs (no
            sudo)... this has to be a setuptools thing.

            Maybe try
            easy_install --version
            sudo easy_install --version

            to see if there's a difference.  Because your sudo is
            broken, you may have to do a lot of "sudo which blah"
            and "which blah" to find out what your problem is.

            You can probably try an install without any sudo use by
            first sudo apt-get remove --purge pip and then
            downloading and using Then just pip install
            pybombs (no flags, no sudo, no nothing)... and try that

            Nick M.

            On Wed, Oct 12, 2016 at 1:13 PM Jason Matusiak
            <>> wrote:

                Hi Nick!
                I did.  When I run it I get:
                Requirement already up-to-date: setuptools in

                I am not on a thin client, I am on a fresh load of
                16.04 on an actual PC.  I do believe that sudo
                isn't actually sudo, but a script.  That said, I
                wasn't having sudo issues before I reloaded my
                machine (which was running 14.04).


                On 10/12/2016 01:04 PM, Nicholas McCarthy wrote:
                Jason, did you try
                pip install --upgrade setuptools

                as a first step?  Are you running on a special
                setup such as a patchwork virtual machine being
                served to you on a thinclient with f**ed permissions?

                Nick M.

                On Wed, Oct 12, 2016 at 10:38 AM Jason Matusiak
                <>> wrote:

                    > Hi Marcus, The reason I went with sudo was
                    because it was erroring outif I didn't:

                    > $ pip install -I --user pybombs
                    > Collecting pybombs
                    >   Using cached PyBOMBS-2.2.0.tar.gz
                    >     Complete output from command python egg_info:

                    > /usr/lib/python2.7/distutils/
                    UserWarning: Unknowndistribution option:

                    >       warnings.warn(msg)

                    > /usr/lib/python2.7/distutils/
                    UserWarning: Unknowndistribution option:

                    >       warnings.warn(msg)
                    >     usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 
[cmd2_opts] ...]
                    >        or: -c --help [cmd1 cmd2 ...]
                    >        or: -c --help-commands
                    >        or: -c cmd --help
                    >     error: invalid command 'egg_info'
                    >     ----------------------------------------

                    > Command "python egg_info" failed
                    with error code 1 in

                    I am still stuck at this stage. Assuming I am
                    dead in the water, what is the next best
                    (approved) way of installing GnuRadio?  Doing
                    it by hand from the github clone?
                    Discuss-gnuradio mailing list

Discuss-gnuradio mailing list

Reply via email to