Hi Robert,

I’m pretty sure you have a corrupt qwt installation on your machine (which
is also 90% the issues users have with gr-inspector).
The file libqwt-qt4.so.5 does not seem to come from qwt-6.1.0 source build,
but from the debian package 'libqwt5-qt4‘.
If you just use a symbolic link and trick cmake into finding this file,
things might go wrong down the road since this is a qwt 5 library! I would
avoid using symlinks for this purpose at all. See my other comments below.

Am 9. April 2018 um 20:26:36, Robert Stanford (rstanford8...@gmail.com)

 Thanks for getting back to me.  The packages I installed were:

 - libqwtplot3d-qt4-0v5, libqwtplot3d-qt4-dev from apt install
 - qwt-6.1.0 (not the most recent, but what the page recommends), from
source.  I'd previously tried installing the most recent from the repos
(apt), but had the same error I mentioned above so uninstalled and
installed this recommended version from source.
   - I installed this using these instructions:

Please uninstall all qwt related packages and files from your machine. As
mentioned above, there seems to be other (broken) qwt installations. This
is not an easy task, so please take some time to clean everything up!

 gr-inspector (cmake) had errors until I did these three things:
  - apt install gnuradio-dev

This is normal if you didn’t build GNU Radio from source.

  - ln -s /usr/include/qwt /usr/include/qwtplot3d-qt4

You are symlinking a qwt directory to a qwtplot3d directory. This does not
make sense to me and will most likely cause problems. All the files you
need should be in /usr/include/qwtplot3d-qt4 and be provided by
‚libqwtplot3d-qt4-dev‘ [1]. If they are not there, something is wrong with
your system.

If the files are there, please share the output of cmake without symlinking

  - ln -s /usr/lib/libqwt-qt4.so.5 /usr/lib/libqwt-qt4.so

Same thing here libqwt-qt5.so.5 is most likely no file from qwt-6.1.0. The
library that you need is in /usr/lib/libqwt.so and is provided by
‚libqwt-dev‘ [2]. If not, again, something is wrong with your system.

  - I found that I had to do this: export
CMAKE_MODULE_PATH=/home/rs/devel/gr-inspector/cmake/Modules; cmake ..

This should also not be necessary. What is the error if you don’t do this?

So, either I am doing something wrong by this point, or there are four
extra steps (above) that are required to get gr-inspector working on my
system (Ubuntu 17.10, gnuradio 3.7.10)

Yes, from the points I mentioned above I don’t think you’re getting a
successful build from here on.

 I've cleaned and built again to show the output.  Here is the output of
'cmake ..': https://pastebin.com/c3hnmNDx

 Here is the output of 'make -j4': https://pastebin.com/zHUAZGn3

 I load the sample graph into gnuradio-companion, and get the error again:

 As for the PLL error (while tuning the rtl-sdr), that's something I
normally experience.  It's never been a show-stopper and I think it can be
ignored in this case.  I am not tuning to 2.4MHz but am using a 2.4MS/s
sample rate.

 Thank you again

[1] https://packages.ubuntu.com/artful/amd64/libqwtplot3d-qt4-dev/filelist

[2] https://packages.ubuntu.com/artful/amd64/libqwt-dev/filelist

Sebastian Müller

On Mon, Apr 9, 2018 at 12:40 PM, Sebastian Müller <gse...@gmail.com> wrote:

> Hi Robert,
> Am 9. April 2018 um 01:31:42, Robert Stanford (rstanford8...@gmail.com)
> schrieb:
>  I have cloned and installed gr-inspector using the instructions on the
> webpage.  One change (addition) necessary to get gr-inspector to install on
> my system (Ubuntu 17.10) was to run ln -s /usr/lib/libqwt-qt4.so.5
> /usr/lib/libqwt-qt4.so ; otherwise cmake failed, unable to find
> libqwt-qt4.so.
> Can you please provide a *complete* list of qwt packages you installed as
> well as the version?  (For instance with `dpkg -s [package]`)
> Also, please provide the output of cmake when before and after the `ln -s`
> command you mention.
> Lastly, I’d like to see the output of `make` after a successful cmake run.
> You can use pastebin or something similar since this all is a lot of output.
>  I have started gnuradio companion and loaded an example from gr-inspector
> (live_signal_detection.grc).  I adjust the sample rate, since I am using an
> RTL-SDR (adjust to 2.4e6).  The graph comes up, and I press 'play' (execute
> the flow graph).  I get this error:
> Found Rafael Micro R820T tuner
> [R82XX] PLL not locked!
> [R82XX] PLL not locked!
> I’m not aware of any RTL SDRs that can be tuned to 2.4 MHz (correct me if
> I’m wrong). That’s probably why you get the PLL error here.
> Traceback (most recent call last):
>   File "/home/rs/devel/gr-inspector/examples/live_signal_detection.py",
> line 142, in <module>
>     main()
>   File "/home/rs/devel/gr-inspector/examples/live_signal_detection.py",
> line 130, in main
>     tb = top_block_cls()
>   File "/home/rs/devel/gr-inspector/examples/live_signal_detection.py",
> line 85, in __init__
>     self.inspector_signal_detector_cvf_0 = 
> inspector.signal_detector_cvf(samp_rate,
> 4096, firdes.WIN_BLACKMAN_hARRIS,
> AttributeError: 'module' object has no attribute 'signal_detector_cvf'
> This just means gr-inspector was not installed correctly. To investigate,
> please provide the outputs I mentioned above.
>  GNUradio (3.7.10) executes other graphs fine (that is, non-gr-inspector
> graphs).  Why am I getting this error with gr-inspector?
>  Thank you
> _______________________________________________
> Discuss-gnuradio mailing list
> Discuss-gnuradio@gnu.org
> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
> Cheers,
> Sebastian Müller
> gse...@gmail.com
> <http://pgp.mit.edu/pks/lookup?op=vindex&search=0x9FFBD55DDC2AA3EE>
> _______________________________________________
> Discuss-gnuradio mailing list
> Discuss-gnuradio@gnu.org
> https://lists.gnu.org/mailman/listinfo/discuss-gnuradio
Discuss-gnuradio mailing list

Reply via email to