OK... The short answer alas is still no...

It reinstalled 3.2 on a PBG4 running 10.4.5 with all updates.
I increased the kernel process slots from 532 to 1000 as suggested.

The configuration was normal, that is

Username Password (8432, xxxxxx...)
Use this proxy server Port 80
Authoxy to run on port 8080 (also tested 8081- see later)
(Also made sure local web server wasn't running)

Enable NTLM Authentication
Domain - CURRICULUM   Host

Then cleared down /var/log/system.log
(Logging locks up if system.log is too big -
perhaps use a separate log here???)

Set SystemPreferences->Network
Wireless connection -> IP address DHCP
and PROXY only on Web Proxy (HTTP) ie port 80 to : 8080
Bypass proxy settings for our domains .blah.blah.blah.vic.edu.au

And fired it all up!!!

The process summary looks like...
 3855  ??  Ss     0:00.09 /usr/sbin/lookupd
4068 ?? S 0:05.51 /Applications/Safari.app/Contents/MacOS/Safari -psn_0_3276801 4076 ?? Ss 0:00.17 /System/Library/Frameworks/SyncServices.framework/Resources/SyncServer.app/Contents/MacOS/SyncServer 4082 ?? Ss 0:00.18 /Library/PreferencePanes/Authoxy.prefPane/Contents/MacOS/authoxyd ODQzMjpzdGFyZHVzdDI= 80 8080 true false CURRICULUM 4485 ?? S 0:00.99 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal -psn_0_3407873
 5305  ??  R      0:00.01 (authoxyd)
 5308  ??  R      0:00.00 (authoxyd)
5309 ?? S 0:00.00 /Library/PreferencePanes/Authoxy.prefPane/Contents/MacOS/authoxyd ODQzMjpzdGFyZHVzdDI= 80 8080 true false CURRICULUM
 4489  p1  Ss     0:00.01 login -pf bruce
 4492  p1  S      0:00.01 -bash
 5310  p1  R+     0:00.00 ps ax
oberon:~ bruce$

So its working... as a process, and forking correctly.
No idea what the TRUE FALSE is.
Attempts to get to the NTLM server and fails there...

The error message is
Unexpected Server response in NTLM authentication Step 2. Giving up.
(repeated 3 times)

Using terminal I can ping the outside world so the network
path exists.
The server is alive and operational
and works with Authoxy 3.1.2!!!

The system.log looks relatively normal really. Can be supplied.

I repeated the whole thing on and even tried
to connect to Authoxy using telnet 8081/0.
That succeeded but without known what commands Authoxy responds to
obviously disconnected.

So, all in all, Back end (127...) connects, Authoxy daemon runs, transmission to the Proxy server works and the proxy returns with an error message on Authentication.

Did you change that section!!!!!!

Kind regards,
PS Temperature here is too hot, going for swim...

Laurent Daudelin wrote:
on 08/03/06 22:10, Heath Raftery at [EMAIL PROTECTED] wrote:

I've been doing a bunch of testing on 3.2 really trying to stress it
hard. I'm afraid I simply cannot reproduce these issues. The odd
thing is that basically very little has changed in the connection
side of things, so this has got me beat at the moment.

I have seen the "unable to create new processes" thing come up
occasionally though and am considering some workarounds. In the mean
time, you could try increasing the maximum number of processes
allowed by the system using sysctl:

To show the current limit:
% sysctl kern.maxproc
To change the limit:
% sudo sysctl -w kern.maxproc=1000

And on my end I'll look into setrlimit and alternative ways to invoke
processes (perhaps akin to Apache or Squid).

I will try to test 3.2 starting tomorrow. I already increased the maximum
number of processes but got the error "Fatal Error: Unable to create new
process. Errno: Resource temporarily unavailable" once today. I will try
with 3.2 to see. I also captured the log generated by Authoxy and have
attached it to this message, although I don't know if it will make it to the

Reply via email to