On 11/13/13 9:53 PM, Javier Richard Quinto A. (Master's student - UNICAMP) wrote:
Hi everyone,

I'm trying to install Open Vswitch 2.0 from souce code on Ubuntu 12.04 server AMD, so I'm using the INSTALL file for the package, but I get errors. Please, you can see below,

- I already installed the Build Requirements, then I run ...

*./configure --with-linux=/lib/modules/`uname -r`/build
*make && make install

Here, all Ok!*
I get errors here ...*
make modules_install*
cd datapath/linux && make modules_install
make[1]: Entrando no diretório `~/openvswitch-2.0.0/datapath/linux'
make -C /lib/modules/3.8.0-29-generic/build M=/home/richardqa/openvswitch-2.0.0/datapath/linux modules_install
make[2]: Entrando no diretório `/usr/src/linux-headers-3.8.0-29-generic'
  INSTALL ~/openvswitch-2.0.0/datapath/linux/openvswitch.ko
Can't read private key

This is not a fatal error, the module is still installed.

  DEPMOD  3.8.0-29-generic
make[2]: Saindo do diretório `/usr/src/linux-headers-3.8.0-29-generic'

The file openvswitch.ko exist and version of my Kernel is *3.8.0-29-generic*

Yeap, that's normal, see above.

ls ~/openvswitch-2.0.0/datapath/linux/openvswitch.ko
root@ubuntu:~/openvswitch-2.0.0# uname -r

And when I run: *insmod datapath/linux/openvswitch.ko*
insmod: *error inserting 'datapath/linux/openvswitch.ko': -1 Unknown symbol in module*

This question was answered in a thread after your question, see this link:


Can anyone help me please?
Saludos Cordiales
Javier Richard Quinto Ancieta
Master's student UNICAMP

discuss mailing list

discuss mailing list

Reply via email to