On Wed, May 21, 2008 at 3:38 AM, Jerome Louvel <[EMAIL PROTECTED]> wrote:
>
> Hi Alex,
>
> Thanks for sharing the Atomojo usage details.
>
> The TunnelService has been turned on since 1.0 and nobody complained (yet)
> about the default query parameters ("method", "charset", "encoding",
> "language" and "media"). If needed they can be renamed by the user. Also
> note that when they are matched, those query parameters are removed from the
> "resourceRef" property.
>
> So the current behavior regarding extensions was not really a fundamental
> change :-), but it's visibility/impact was greater than for query parameters
> and gave you this feeling. It definitely indicates that there is a lack of
> documentation regarding the semantics of the "resourceRef" property.
>
> Currently, when the extensions are touched, the TunnelService puts the
> original reference in a "org.restlet.TunnelService.originalRef" attribute of
> the request. But this is not very easy to use.
>
> So, I propose to replace this attribute by a more explicit
> "Request.originalRef" property and clearer Javadocs regarding
> "Request.resourceRef" whit cross-refs with "originalRef".
>
> Would that work for you?Would Request.originalRef still have getRemainingPart() returning the unmatched portion? Either way, this works for me because I can just turn it off for my uses (which is what I did) and everything works as expected. --Alex Milowski

