This mailing list is for the development of Django itself, not for support
using Django. Please use. the django-users mailing list for that, or IRC
#django on freenode, or a site like Stack Overflow.

Additionally your problem is not related to Django but to installing
mysqlclient, a package that Django uses. Whilst I've used that library I
have no experience around windows setup issues. The package is at
https://pypi.org/project/mysqlclient/ , with its homepage at
https://github.com/PyMySQL/mysqlclient-python , you might be able to find
support on the issues there (check through old closed issues first before
raising a new one).

Hope that helps,

Adam

On Mon, 28 Jan 2019 at 17:40, Desh Deepak <deshdeepak...@gmail.com> wrote:

> Hi, everyone i unable to install mysql client in cmd. when i going for
> connect to mysql database using django for web project.
>
> error message showed me in cmd.
>
>
> """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
> Microsoft Windows [Version 10.0.16299.15]
> (c) 2017 Microsoft Corporation. All rights reserved.
>
> C:\Users\deshd>pip install django mysqlclient
> Requirement already satisfied: django in
> c:\users\deshd\appdata\local\programs\python\python37-32\lib\site-packages
> (2.1.4)
> Collecting mysqlclient
>   Using cached
> https://files.pythonhosted.org/packages/de/d7/919042fb7ed78a89e21c4e43d5daed90d5df18ec183bae3de493a7d9e3ed/mysqlclient-1.4.1.tar.gz
> Requirement already satisfied: pytz in
> c:\users\deshd\appdata\local\programs\python\python37-32\lib\site-packages
> (from django) (2018.5)
> Building wheels for collected packages: mysqlclient
>   Building wheel for mysqlclient (setup.py) ... error
>   Complete output from command
> c:\users\deshd\appdata\local\programs\python\python37-32\python.exe -u -c
> "import setuptools,
> tokenize;__file__='C:\\Users\\deshd\\AppData\\Local\\Temp\\pip-install-tgvhtai_\\mysqlclient\\setup.py';f=getattr(tokenize,
> 'open', open)(__file__);code=f.read().replace('\r\n',
> '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d
> C:\Users\deshd\AppData\Local\Temp\pip-wheel-7wirzw5i --python-tag cp37:
>   running bdist_wheel
>   running build
>   running build_py
>   creating build
>   creating build\lib.win32-3.7
>   creating build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\__init__.py -> build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\_exceptions.py -> build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\compat.py -> build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\connections.py -> build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\converters.py -> build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\cursors.py -> build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\release.py -> build\lib.win32-3.7\MySQLdb
>   copying MySQLdb\times.py -> build\lib.win32-3.7\MySQLdb
>   creating build\lib.win32-3.7\MySQLdb\constants
>   copying MySQLdb\constants\__init__.py ->
> build\lib.win32-3.7\MySQLdb\constants
>   copying MySQLdb\constants\CLIENT.py ->
> build\lib.win32-3.7\MySQLdb\constants
>   copying MySQLdb\constants\CR.py -> build\lib.win32-3.7\MySQLdb\constants
>   copying MySQLdb\constants\ER.py -> build\lib.win32-3.7\MySQLdb\constants
>   copying MySQLdb\constants\FIELD_TYPE.py ->
> build\lib.win32-3.7\MySQLdb\constants
>   copying MySQLdb\constants\FLAG.py ->
> build\lib.win32-3.7\MySQLdb\constants
>   running build_ext
>   building 'MySQLdb._mysql' extension
>   error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft
> Visual C++ Build Tools": https://visualstudio.microsoft.com/downloads/
>
>   ----------------------------------------
>   Failed building wheel for mysqlclient
>   Running setup.py clean for mysqlclient
> Failed to build mysqlclient
> Installing collected packages: mysqlclient
>   Running setup.py install for mysqlclient ... error
>     Complete output from command
> c:\users\deshd\appdata\local\programs\python\python37-32\python.exe -u -c
> "import setuptools,
> tokenize;__file__='C:\\Users\\deshd\\AppData\\Local\\Temp\\pip-install-tgvhtai_\\mysqlclient\\setup.py';f=getattr(tokenize,
> 'open', open)(__file__);code=f.read().replace('\r\n',
> '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record
> C:\Users\deshd\AppData\Local\Temp\pip-record-ykdv80km\install-record.txt
> --single-version-externally-managed --compile:
>     running install
>     running build
>     running build_py
>     creating build
>     creating build\lib.win32-3.7
>     creating build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\__init__.py -> build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\_exceptions.py -> build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\compat.py -> build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\connections.py -> build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\converters.py -> build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\cursors.py -> build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\release.py -> build\lib.win32-3.7\MySQLdb
>     copying MySQLdb\times.py -> build\lib.win32-3.7\MySQLdb
>     creating build\lib.win32-3.7\MySQLdb\constants
>     copying MySQLdb\constants\__init__.py ->
> build\lib.win32-3.7\MySQLdb\constants
>     copying MySQLdb\constants\CLIENT.py ->
> build\lib.win32-3.7\MySQLdb\constants
>     copying MySQLdb\constants\CR.py ->
> build\lib.win32-3.7\MySQLdb\constants
>     copying MySQLdb\constants\ER.py ->
> build\lib.win32-3.7\MySQLdb\constants
>     copying MySQLdb\constants\FIELD_TYPE.py ->
> build\lib.win32-3.7\MySQLdb\constants
>     copying MySQLdb\constants\FLAG.py ->
> build\lib.win32-3.7\MySQLdb\constants
>     running build_ext
>     building 'MySQLdb._mysql' extension
> *    error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft
> Visual C++ Build Tools": https://visualstudio.microsoft.com/downloads/
> <https://visualstudio.microsoft.com/downloads/>*
>
> """""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""
> I already download *Microsoft Visual C++ 14.0.*
>
> --
> You received this message because you are subscribed to the Google Groups
> "Django developers (Contributions to Django itself)" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to django-developers+unsubscr...@googlegroups.com.
> To post to this group, send email to django-developers@googlegroups.com.
> Visit this group at https://groups.google.com/group/django-developers.
> To view this discussion on the web visit
> https://groups.google.com/d/msgid/django-developers/CAJ0m4xgNJ1WmBc0dse9-in_bHH7R4RChHTxMggOq%2B%3DpqGQF1Pw%40mail.gmail.com
> <https://groups.google.com/d/msgid/django-developers/CAJ0m4xgNJ1WmBc0dse9-in_bHH7R4RChHTxMggOq%2B%3DpqGQF1Pw%40mail.gmail.com?utm_medium=email&utm_source=footer>
> .
> For more options, visit https://groups.google.com/d/optout.
>


-- 
Adam

-- 
You received this message because you are subscribed to the Google Groups 
"Django developers  (Contributions to Django itself)" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to django-developers+unsubscr...@googlegroups.com.
To post to this group, send email to django-developers@googlegroups.com.
Visit this group at https://groups.google.com/group/django-developers.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-developers/CAMyDDM1LS-24W7pQQu8h%2Bkfj440zHrknB%2B4CkWpQ7h1wp2XV4Q%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to