#31592: Reverting Django 3.1. to Django 3.0.6 raises "binascii.Error: Incorrect
padding".
------------------------------+--------------------------------------
     Reporter:  אורי          |                    Owner:  nobody
         Type:  Bug           |                   Status:  closed
    Component:  Core (Other)  |                  Version:  3.1
     Severity:  Normal        |               Resolution:  invalid
     Keywords:                |             Triage Stage:  Unreviewed
    Has patch:  0             |      Needs documentation:  0
  Needs tests:  0             |  Patch needs improvement:  0
Easy pickings:  0             |                    UI/UX:  0
------------------------------+--------------------------------------

Comment (by אורי):

 Does this error also occur if I migrate forward (from 3.0 to 3.1) or only
 backwards?

 Anyway, I think Django should be able to delete the relevant cache when
 migrating (backwards or forward) and not just raise exceptions which don't
 make sense to the users. Maybe just check the version of the session
 objects and if it's not correct then delete them.

-- 
Ticket URL: <https://code.djangoproject.com/ticket/31592#comment:3>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to django-updates+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/069.c6a9b51190ea89339491b5167d00e67d%40djangoproject.com.

Reply via email to