#33060: Add a helper function to make and validate cache keys.
-------------------------------------+-------------------------------------
     Reporter:  Nick Pope            |                    Owner:  Nick Pope
         Type:                       |                   Status:  closed
  Cleanup/optimization               |
    Component:  Core (Cache system)  |                  Version:  dev
     Severity:  Normal               |               Resolution:  fixed
     Keywords:                       |             Triage Stage:  Ready for
                                     |  checkin
    Has patch:  1                    |      Needs documentation:  0
  Needs tests:  0                    |  Patch needs improvement:  0
Easy pickings:  0                    |                    UI/UX:  0
-------------------------------------+-------------------------------------
Changes (by Mariusz Felisiak <felisiak.mariusz@…>):

 * status:  assigned => closed
 * resolution:   => fixed


Comment:

 In [changeset:"42dfa97e191d8f7ffdc0b5d9502949ef3b8ef356" 42dfa97e]:
 {{{
 #!CommitTicketReference repository=""
 revision="42dfa97e191d8f7ffdc0b5d9502949ef3b8ef356"
 Fixed #33060 -- Added BaseCache.make_and_validate_key() hook.

 This helper function reduces the amount of duplicated code and makes it
 easier to ensure that we always validate the keys.
 }}}

-- 
Ticket URL: <https://code.djangoproject.com/ticket/33060#comment:8>
Django <https://code.djangoproject.com/>
The Web framework for perfectionists with deadlines.

-- 
You received this message because you are subscribed to the Google Groups 
"Django updates" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion on the web visit 
https://groups.google.com/d/msgid/django-updates/065.8043b33519464cda7fb32124148bf262%40djangoproject.com.

Reply via email to