On 05/16/2014 01:58 PM, Maddox Flower wrote:
> Thanks for the reply, Yuri! Unfortunately, I am still not able to access to 
> spools directory. Here's the output of
> $> ps axuw | grep apache
> apache   26077  0.0  0.0 131484  3204 ?        S    13:36   0:00 
> Is that ok? I've gone through the whole setup once more (after removing the 
> /var/spool/dl directory and the dl directory in my websites httpdocs). Still 
> the same error :-(

It's running as "apache". Try "chown -r apache [spool]".

> What about ownership / group / permissions of the 
> /var/www/vhosts/<my_domain>/httpdocs/dl directory, are they important at 
> all?
> Can this have anything to do with the <Directory> entry? This is supposed to 
> be in my /etc/httpd/conf/httpd.conf file, right? I am a bit confused about 
> the mod_php. Is this module loaded by apache (v2.2.15) by default?

Apache and PHP can be configured in many ways. mod_php is usually the
default/recommended choice. In this configuration, PHP runs as the same
user/group as apache.

DL has two parts you need to care about: the htdocs directory
(/var/www/vhosts/<my_domain>/httpdocs/dl in your case) and the spool

htdocs needs to be readable _only_. By the error that you're getting,
this is already readable so that's fine.

The spool needs to readable _and_ writable as well by the apache user.
A "chown -r apache /var/spool/dl" should do it.

I think I suggested a chgrp before (which is what I usually do), but
then you should look into which group apache is running at (Group line
in the apache configuration file in the simplest case). Generally on
Debian/Ubuntu is www-data, on RedHat/Centos you need to check.

Reply via email to