On Thu, May 02, 2024 at 08:59:43PM +0200, Martin Wilck wrote:
> This series goes on top of Benjamin Marzinksi's late "multipath: fix hang
> in flush_map_nopaths" series. It introduces no functional changes. It
> just combines the multiple boolean arguments to _dm_flush_map() and
> dm_simplecmd() into a flags variable. This reduces the number of
> function arguments, but that's not the main intention. The symbolic
> flags improve the readability of the code by making it obvious which
> flags are passed to the respective functions in their callers.

Nice cleanup. For the set:
Reviewed-by: Benjamin Marzinski <[email protected]>
> 
> Martin Wilck (3):
>   libmultipath: use bitwise flags for map flushing API
>   libmultipath: use bitwise flags for dm_simplecmd API
>   libmultipath: add argument names to some prototypes
> 
>  libmultipath/devmapper.c | 94 ++++++++++++++++++----------------------
>  libmultipath/devmapper.h | 33 +++++++++-----
>  2 files changed, 62 insertions(+), 65 deletions(-)
> 
> -- 
> 2.44.0


Reply via email to