The following aresome extracts from emails I've had with Katolaz.I downloaded 
a fresh copy of netinstall to do a fresh install on baremetal on an SSD on 
which I had Devuan working before; an upgrade fromJessie. I started from 
scratch.  I had the drive set up likethis: During the Netinstall using 
Graphical Mode, I found someinteresting behavior and I thought I would try and 
document it. I hadthe hard drive (250GB SSD) set up for some possible 
experimentationwith dual booting DOS later, whatever, and to create a possible 
corner case forthe install. 
(BTW, the Screenshot captures during Graphical Installmode do not appear to be 
 Here's the drive:  

   /dev/sda1    2GB  /dos    FAT16  (first partition – previously formatted)

   /dev/sda2    2GB  /boot   ext2

   /dev/sda3    Extended Partition  /dev/sda4    2GB  /       ext2

   /dev/sda5   40GB  /usr    ext3

   /dev/sda6  150GB  /home   ext3 

   /dev/sda7    5GB  /var    ext3 

   /dev/sda8    5GB  /opt    ext3

   /dev/sda9    5GB  /usr/local ext3


   The installation got to some point in the "Select and Install software" step 
and stopped with a failure to mount on one of the ext3 drives. Continue, took 
me back to the "Select and Install software" list.  I tried 2-3 times with the 
same result: back to the list on the same step. So I backed up to partition the 
drives step and selected each partition in order to re-format them.  There is 
no option to force a format of FAT partitions so I let it go.  After continue, 
I got a "found uncorrected errors" on the FAT16 partition. Since I didn't have 
a format option, I decided to change it to FAT32. ( figured this would force a 
reformat).  This got past that error.  As I recall, the install got back to 
about the same point deep in the Select and Install step and produced the same 
mount error.  Continue, took me back to the list.  So I backed up to the 
partitioning step again and went through and selected the "erase all data" 
option to clear the data fields on all partitions.  This did not change the 
failure, so I went back to the partition step.  BTW, when it was failing the 
FAT16 and I changed it to FAT32 it got pass that point.  Next time around, I 
got the "found uncorrected errors" message on the FAT32 partition. Upon 
changing it to back to FAT16, (which forces a re-format), I could get past this 
error on that pass through the partitioning step.  Then I got an "unable to 
mount" failure on one of the ext3 partitions.  Since there is no way to force a 
reformat option on that failing drive (the option is missing from the menu 
--and I didn't change the fs type), the only way I could figure out to reformat 
that partition was to change the file system type so I changed it to ext4.  
This solved the error on that partition,  but the problem immediatly moved to 
another ext3 partition. This kept happening on each pass until I had visited 
all but one of the ext3 partitions. [Perhaps, these subsequent errors is 
because I used the "erase all data" option on all of them? Does this write only 
to the data area only or does it erase part of the file system?]

   This looks like reusing stale data without properly re-intializing the 
variable(s). I suspected the graphical presentation software at the time but I 
have no hard evidence.  [At the point of install mount failure, it indicates 
that there is more information in  /var/log/syslog  and/or  Terminal4. (I think 
that's alt-F4?)  Of course, not having finished the install, the isn't enough 
functionality to get to those. I'm thinking I should be able to live-boot 
Knoppix and maybe mount the /var partition and look at the syslog if I knew how 
to view the partitions at that point, and then if I knew what to grep for in 
the log.] 
  So I left the Graphical Mode and started using the "Install" option.  
Installation went through to completion.   Booted and logged in. Everything is 
so slooooow. Don't know who is sucking up the cpu. Also there is no wireless 
connection to the internet even though it just finished installing via the 
internet. Launching wicd does not find anything. I don't know how to use the ip 
commands to debug that or get the status of the adapter. 

 Continuing the nextday I did some testing. I could not induce a mounting 
error, sothat's a different problem. That question becomes “Does theGraphical 
Install option recover correctly from a “failure tomount” condition?"    Here's 
the pattern I've discovered. If I have the partitions set up as described 
above, and I go through the manual setup process I can consistently reproduce 
the "uncorrected errors" error found on sda1. 
  After some searches on the internet, I discovered the following: 
  BTW,There is nothing in my G555 bios settings related to gpt or UEFI. 

  IIRC, I formated the drive earlier using the GParted (gksu) option found in 
my Refracta fall back setup I have on a different SSD. So I assume its standard 
bios/FAT partitions.  The 'partman' partitioner does not complain that the 
first partition on the drive was a FAT partition, nor did it complain that it 
was defined as 2GB.  However, I did reduce the size to 200 MB and that was 
accepted.  2GB was now rejected. 268 MB works but 269 does not.  If you attempt 
269MB or greater, partman will ask if you want to change a FAT16 to a FAT32 
partition, and if so, it warns that any installed windows OS will be destroyed. 
With 'no format F' option scheduled for the FAT partition, you will encounter 
the "Uncorrected Errors" problem.  At one point I encounted the following error 
message : "GNU Parted cannot resize this partition to this size. We're working 
on it!"  
   This message can be found in this link: 
  And here:
  And here: 
  Some copy from the bug and its workaround I include here: <copy> 
Unfortunately support for resizing FAT16 and FAT32 file systems is being 
removed from the libparted library.  The last version of libparted that does 
support resizing is the recently released parted-2.4.

The announcement regarding removal of FAT16 and FAT32 file system resizing from 
parted is available at the following link:

The commit that removes the resizing capability can be viewed at the following 

Hopefully someone will develop a resizing utility to fill this void. 
  Curtis Gedak 2016-01-05 18:00:04 UTC  Status Update:

libparted 3.0 - removed FAT16/FAT32 and HFS/HFS+ file system resize
libparted 3.1 - added back FAT16/32 and HFS/HFS+ file system resize
                capability in a separate library
libparted 3.2 - also has this separate resize library

The inability to resize FAT16/FAT32 file systems that are less than 256 MB 

Workaround:  Resizing FAT16/FAT32 Partitions (less than 256 MB)

  1.  Backup the data in the FAT16/FAT32 partition
  2.  Reformat the partition to EXT4
  3.  Resize EXT4 partition to desired partition size
  4.  Reformat the partition back to FAT16/FAT32
  5.  Restore the FAT16/FAT32 files from backup

Note that if you use file system labels you may wish to re-label the partition 
at this time. </copy> 
  Here is an associated patch: 
  And here is a note from that patch: 

    Note that we are removing the resize command, even though parted

    appears to be the only free tool that provides the ability to

    resize FAT16 and FAT32 file systems.

 One commenter says " didn't do anything wrong, the FAT resizer is 
buggy."   Does this mean that the workaround "Solves" the problem? Also, are 
there any implications as to the use of a U/EFI partition as the first 
    Are there any restrictions as to the use of FAT16/32 partitions in Devuan?


    And, if 'partman' is the default install partitioner in Devuan, what is the 
warning on this page all about?   

    <quote from that (partman-partitioning) link >

 debian-installer udeb package
   Warning: This package is intended for the use in building debian-installer 
images only. Do not install it on a normal Debian system.   </quote>    
  I don't know the history of partman or its inheritance tree.  Question: How 
does any of this affect Devuan and its install process? 
Finally, I decidedto let it do an automatic install with minimum intervention. 
Itinstalled completely and after reboot, there is no networkconnection. And 
I've timed it; after clicking on the network button,it takes ~18 seconds for 
the wicd window to open. Running top,nothing seems to be hogging the cpu. Wicd 
fails to find anynetworks. (I now see other discussion on this subject on the 
  (BTW, I notice that always fails)
Just one last note,I believe it was during one of the install passes using 
Graphical,the install got near the finish line and dumped me into a 
TTY1terminal screen. I didn't know what I might look for at that point. 
Anysuggestions (with verbose commands)?
Finally, I'd just like to saya big Thank You for all you VAU's for a 
back-to-sanity preservationof the *nix philosophy. If there are any experiments 
you would likerun, let me know. I'll try.
Dng mailing list

Reply via email to