On 2/14/20 3:37 AM, Ozi Traveller via Dng wrote:
Does this help? You've probably seen this already.....

https://mike632t.wordpress.com/2019/11/17/gksu-is-dead-long-live-pkexec/

https://www.freedesktop.org/software/polkit/docs/0.105/pkexec.1.html

On Fri, Feb 14, 2020 at 12:28 PM Gastón via Dng <dng@lists.dyne.org 
<mailto:dng@lists.dyne.org>> wrote:

    On Thu, Feb 13, 2020 at 03:16:58PM -0800, tom wrote:
     > On Thu, 9 Jan 2020 16:50:15 +0000
     > Mark Hindley <m...@hindley.org.uk <mailto:m...@hindley.org.uk>> wrote:
     >
     > > On Thu, Jan 09, 2020 at 05:44:17PM +0100, Alessandro Vesely via Dng
     > > wrote:
     > > > Hi,
     > > >
     > > > is there a recommended GUI package browser for Devuan?
     > > >
     > > > After migrating, synaptic isn't installed.  If I try to install it,
     > > > it says it needs policykit-1.  Since the latter seems to be akin to
     > > > systemd, I reply 'n'.
     > >
     > > I really don't think that is true. There is no direct relationship
     > > between policykit-1 and systemd. And our policykit works with either
     > > elogind or consolekit, so you have options.
     > >
     > > If you want a integrated gui desktop that allows you to do privileged
     > > things like install packages, you will need policykit-1 or something
     > > similar.
     > >
     > > Alternatively, use apt or aptitude from the commandline.
     > >
     > > Mark
     > > _______________________________________________
     > > Dng mailing list
     > > Dng@lists.dyne.org <mailto:Dng@lists.dyne.org>
     > > https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng
     >
     > Sorry, can you explain why exactly polkit is needed here? What is wrong
     > with what everyone was doing before polkit which was gksu or gksudo?
     >
    gksu is no longer available from Beowulf. Now, apparently, you have to
    use: pkexec

    I'm in touch with the GNU/EterTics developer and he's having trouble
    running d-i from Live Mode on a beta version with Beowulf he's testing.

    He used to launch the d-i from Live mode using this command:
    `su-tu-root-X-c /usr/sbin/debian-installer-launcher`, but su-tu-root is
    no longer available.

    When he wants to launch the d-i from Live mode using this command:
    `pkexec /usr/sbin/debian-installer-launcher` , the installer does not
    start in GUI mode.

    Yesterday we tried several alternatives, like this one, but without
    success:

    We tried running it this way:
    `pkexec env DISPLAY=$DISPLAY XAUTHORITY=$XAUTHORITY
    /usr/sbin/debian-installer-launcher` , with this it tries to open a
    window, but closes immediately.

    We couldn't get pkexec to run the d-I in GUI mode from live-version.
    Nor is there much documentation about its use available.

    Has anyone been through this using pkexec?




Hi,
you can try with sudo I tested it with synaptic and it seems to work:

1) add the live-mode user to /etc/sudoers with the nopasswd directive
   for the needed command e.g.:
   live-user ALL=(ALL) NOPASSWD: /usr/sbin/synaptic

2) run sudo synaptic from a commandline in the live session
   or add it to a panel launcher (works in xfce)
   or edit a .desktop file

Hope this helps.

Ciao,
Tito

_______________________________________________
Dng mailing list
Dng@lists.dyne.org
https://mailinglists.dyne.org/cgi-bin/mailman/listinfo/dng

Reply via email to