* Christoph <c...@appliedprivacy.net> [190513 20:42]:
> The following packages have unmet dependencies:
> dnsdist : Depends: libprotobuf17 but it is not going to be installed
> Depends: libre2-5 (>= 20131024+dfsg) but it is not going to be installed
> Depends: libsnmp30 (>= 5.7.3+dfsg) but it is not going to be installed
> Depends: libstdc++6 (>= 6) but it is not going to be installed
> E: Unable to correct problems, you have held broken packages.
> 
> Is anyone else using today's master builds?

In the buster development cycle there was a gcc issue that affected
a number of C++ programs, including dnsdist (and pdns-recursor).
This was "solved" in Debian by having libstdc++6 break the older
versions, but that clearly breaks the very reasonable special
versioning of the repo.powerdns.com master-branch packages.

This is tracked as https://github.com/PowerDNS/pdns/issues/7781

Cheers,
Chris

-- 
Chris Hofstaedtler / Deduktiva GmbH (FN 418592 b, HG Wien)
www.deduktiva.com / +43 1 353 1707
_______________________________________________
dnsdist mailing list
dnsdist@mailman.powerdns.com
https://mailman.powerdns.com/mailman/listinfo/dnsdist

Reply via email to