On 09/05/17 19:35, Petr Menšík wrote:
> Hi Simon, hi everyone.
> 
> Fedora wants to move from IDN 2003 to IDN 2008 support. Dnsmasq already
> supports IDN, but only older version. There is really little of IDN to
> support. I made a patch that allows explicit support for libidn2 along
> with original libidn. Because simple packaging, I could not use
> HAVE_IDN2. I chose HAVE_LIBIDN2 as a replacement.
> 
> A link to Fedora bug, if you want to try difference:
> https://bugzilla.redhat.com/show_bug.cgi?id=1449150
> 
> Could it be merged?
> 

Is there any point in supporting both libraries? I'm not sure what the
point is. Any build which includes the IDN support (which is, broadly
distribution packages) will change to libidn2 so the libidn support just
becomes support overhead moving forward. It won't give people the old
behaviour unless they recompile.

I could see slightly more point to an option which allowed the user to
specify IDN2003 rather than IDN2008 behaviour. It looks like that could
be done by forcing the IDN2_TRANSITIONAL flag to the  idn2_to_ascii_lz()
call.

Cheers,

Simon.



Attachment: signature.asc
Description: OpenPGP digital signature

_______________________________________________
Dnsmasq-discuss mailing list
Dnsmasq-discuss@lists.thekelleys.org.uk
http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

Reply via email to