On Fri, Feb 16, 2018 at 09:03:02AM -0800, Todd A wrote:
> On Thu, Feb 15, 2018 at 2:46 PM, Andy Ruddock wrote:
> 
>    Todd Andrews wrote:
>     > Hi All,
>     >
>     > It's getting an IP address of 192.168.1.115. I
>     > first noticed the problem when I tried to establish a VNC
>     > connection to it
>     > because I can't connect via its hostname, "sagan", but I can
>     > connect via its IP address.
>     >
>     > Neither the IP assignment nor the laptop's MAC address appear in
>     > dnsmasq.leases. The only reason I know it is assigned .115 is by
>     > physically
>     > going to the laptop and running the Windows 'ipconfig' program at the
>     > command prompt.
>     >
>     > I've rebooted the Raspberry Pi and the Windows 10 laptop, but it
>     > hasn't made a difference.
>     >
>     > More info below. Does anyone have any ideas?
>     >
>     > Regards,
>     > Todd
> 
> Hi Andy, thanks for getting back to me so quickly. (I originally
> sent this reply yesterday but forgot there's a maximum size per post
> to this list. Replaced screen capture with a link below.)
> 
> 
>    Are you sure the windows box hasn't been configured with a static IP
>    address?
> 
> 
> I'm positive: click to view screen capture 
> <https://www.dropbox.com/s/cwy72yu4sly62mp/sagan-configured-as-dhcp.PNG?dl=0>
> 
>    Any information when you refresh the IP address from within a cmd window
>    in Windows?
>             ipconfig /renew
> 
> 
> I never would have thought to try this. It gave a strange error but
> renewing fixed the problem immediately. Here's the error:
> 
>    C:\Users\taa>ipconfig /renew
> 
>    Windows IP Configuration
> 
>    An error occurred while renewing interface Ethernet : The name
>    specified in the network control block (NCB) is in use on a remote
>    adapter.
>    The NCB is the data.
> 
>    C:\Users\taa>
> 
> 
> Having a specific error allowed me to Google it and find Bizarre
> DHCP server error solved 
> <https://web.archive.org/web/20161126203756/http://www.formortals.com/bizarre-dhcp-server-error-solved/>.
> The poster at that link 1) was not getting an IP address at all, 2)
> was running a Windows DHCP server, and 3) "found a second
> reservation in DHCP which looked odd; it had the same IP address as
> the first one that we deleted but it had an entirely different MAC
> and name."
> 
> This made me remember that a couple of weeks ago I changed my
> laptop's Computer Name in Windows.
> 
> Does this mean there is some other place where dnsmasq might have
> cached the IP address or MAC or hostname? I'm trying to figure out
> why dnsmasq.leases had no reference to the laptop's IP/MAC/hostname,
> neither the previous hostname or the new one.

My guess would be
| dhcp-host=f4:8e:38:xx:xx:xx,sagan
as the original post mentioned. And assuming that dnsmasq is smart enough
to not log what is already documented in the (static) configuration.



> Maybe this is one of those cases that is so bizarre
> it defies explanation (and I can live with that). :D


I would culprit the host renaming.

Matching XKCD item at https://www.xkcd.com/910/   :-)


Groeten
Geert Stappers
-- 
Leven en laten leven

_______________________________________________
Dnsmasq-discuss mailing list
Dnsmasq-discuss@lists.thekelleys.org.uk
http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

Reply via email to