1 февраля 2019 г., 19:33, "Geert Stappers" <stapp...@stappers.nl> написал:

> On Fri, Feb 01, 2019 at 03:47:29PM +0000, Roman Dmitriev wrote:
> 
>> Hello,
>> 
>> When trying to build dnsmasq version 2.79 falls out with an error:
>> 
>> cc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions 
>> -fstack-protector-strong
>> --param=ssp-buffer-size=4 -grecord-gcc-switches 
>> -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -m64
>> -mtune=generic -DHAVE_DBUS -DHAVE_LIBIDN2 -DHAVE_DNSSEC -DVERSION='"2.79"' 
>> -I/usr/include/dbus-1.0
>> -I/usr/lib64/dbus-1.0/include -c crypto.c
>> crypto.c:25:26: fatal error: nettle/eddsa.h: No such file or directory
> 
> Repeating the 'No such file or directory'
> 
>> #include <nettle/eddsa.h>
>> ^
>> compilation terminated.
>> make[1]: *** [crypto.o] Error 1
>> make[1]: Leaving directory `/home/roman/BUILD_ROOT/BUILD/dnsmasq-2.79/src'
>> make: *** [all] Error 2
>> 
>> In Centos 7 last version of nettle:
>> 
>> $ rpm -qi nettle
>> Name : nettle
>> Version : 2.7.1
>> Release : 8.el7
>> 
>> Dnsmasq required nettle >=3.
>> 
>> But the build of this version nettle for Centos 7 breaks the
>> dependencies of the rest of the distribution packages, making it
>> impossible to update them.
>> Is it possible to build a package with the old library?
> 
> (here a .deb system, what follows is _not_ tested)
> 
> Try `rpm -qi nettle\*`, it should show "nettle-devel".
> If not `sudo yum install nettle-devel`
> 
> Please, let us know how it went.
> 
> Groeten
> Geert Stappers
> --
> Leven en laten leven
> 
> _______________________________________________
> Dnsmasq-discuss mailing list
> Dnsmasq-discuss@lists.thekelleys.org.uk
> http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

[ro...@centos7.one.local ~/BUILD_ROOT/BUILD/dnsmasq-2.79]$ rpm -qa | grep nettle
nettle-2.7.1-8.el7.x86_64
nettle-devel-2.7.1-8.el7.x86_64
[ro...@centos7.one.local ~/BUILD_ROOT/BUILD/dnsmasq-2.79]$
[ro...@centos7.one.local ~/BUILD_ROOT/BUILD/dnsmasq-2.79]$ rpm -ql 
nettle-devel-2.7.1-8.el7.x86_64
| grep eddsa
[ro...@centos7.one.local ~/BUILD_ROOT/BUILD/dnsmasq-2.79]$
[ro...@centos7.one.local ~/BUILD_ROOT/BUILD/dnsmasq-2.79]$ rpm -ql 
nettle-devel-2.7.1-8.el7.x86_64
| grep ecdsa
/usr/include/nettle/ecdsa.h
[ro...@centos7.one.local ~/BUILD_ROOT/BUILD/dnsmasq-2.79]$ grep nettle ./*
./CHANGELOG: versions of libnettle. We now require libnettle 3.

-
Roman Dmitriev
mailto: r...@rajven.ru

_______________________________________________
Dnsmasq-discuss mailing list
Dnsmasq-discuss@lists.thekelleys.org.uk
http://lists.thekelleys.org.uk/mailman/listinfo/dnsmasq-discuss

Reply via email to