I've stumbled upon a weird problem with IPv6 DHCP with DNSMasq.
I have a /48 IPv6 prefix. For example let it be AAAA:AAAA:AAAA::
The interface on which DNSMasq receives the DHCP/RA queries is, for
example, tap0 (it's for a VPN server) with an assigned address of
Now I wanted to create a dual DHCP/SLAAC configuration, but instead of
making them both on the same prefix, I wanted to split them into
subprefixes, i.e.:
all static DHCPv6 queries would be assigned on AAAA:AAAA:AAAA:1::
all dynamic DHCPv6 queries would be assigned on AAAA:AAAA:AAAA:2::
all SLAAC configuration would be done on AAAA:AAAA:AAAA:FF00::
Each on it's own /64 prefix.
I've tried to set it up, but it seems that each time I define it like this:
dhcp-range=tap0, AAAA:AAAA:AAAA:FF00::,slaac,ra-stateless,ra-only,64 #for
dhcp-range=tap0, AAAA:AAAA:AAAA:2::,64,1h #for dynamic DHCPv6
I just don't get a lease at all... Which is probably logical.
When I try to specify the actual prefix of 48 instead of 64, I get the error
"prefix length must be at least 64"
even for the dynamic DHCPv6 option.
I've worked around that by assigning IPs to the tap0 interface of
but it really feels like a hack than a real solution.
Is there any cause why we can't set a prefix-len smaller than 64, to allow
configuring different subprefixes differently?

Dnsmasq-discuss mailing list

Reply via email to