Hello, I use symfony and I want to upgrade doctrine/common to v.2.7 to use 
php 7.1 null types...

Now I have in composer.json:

"doctrine/orm": "^2.5",
"doctrine/doctrine-bundle": "^1.6",
"doctrine/doctrine-cache-bundle": "^1.2",


I tried to add:

"doctrine/common": "^2.7",


But I get this error:

    - doctrine/orm v2.5.5 requires doctrine/common >=2.5-dev,<2.7-dev -> 
satisfiable by doctrine/common[2.5.x-dev, 2.6.x-dev, v2.5.0, v2.5.0-beta1, 
v2.5.1, v2.5.2, v2.5.3, v2.6.0, v2.6.1, v2.6.2] but these conflict with 
your requirements or minimum-stability.
    - doctrine/orm v2.5.5 requires doctrine/common >=2.5-dev,<2.7-dev -> 
satisfiable by doctrine/common[2.5.x-dev, 2.6.x-dev, v2.5.0, v2.5.0-beta1, 
v2.5.1, v2.5.2, v2.5.3, v2.6.0, v2.6.1, v2.6.2] but these conflict with 
your requirements or minimum-stability.
    - doctrine/orm v2.5.4 requires doctrine/common >=2.5-dev,<2.7-dev -> 
satisfiable by doctrine/common[2.5.x-dev, 2.6.x-dev, v2.5.0, v2.5.0-beta1, 
v2.5.1, v2.5.2, v2.5.3, v2.6.0, v2.6.1, v2.6.2] but these conflict with 
your requirements or minimum-stability.
    - doctrine/orm v2.5.3 requires doctrine/common >=2.5-dev,<2.7-dev -> 
satisfiable by doctrine/common[2.5.x-dev, 2.6.x-dev, v2.5.0, v2.5.0-beta1, 
v2.5.1, v2.5.2, v2.5.3, v2.6.0, v2.6.1, v2.6.2] but these conflict with 
your requirements or minimum-stability.
    - doctrine/orm v2.5.2 requires doctrine/common >=2.5-dev,<2.6-dev -> 
satisfiable by doctrine/common[2.5.x-dev, v2.5.0, v2.5.0-beta1, v2.5.1, 
v2.5.2, v2.5.3] but these conflict with your requirements or 
minimum-stability.
    - doctrine/orm v2.5.1 requires doctrine/common >=2.5-dev,<2.6-dev -> 
satisfiable by doctrine/common[2.5.x-dev, v2.5.0, v2.5.0-beta1, v2.5.1, 
v2.5.2, v2.5.3] but these conflict with your requirements or 
minimum-stability.
    - doctrine/orm v2.5.0 requires doctrine/common >=2.5-dev,<2.6-dev -> 
satisfiable by doctrine/common[2.5.x-dev, v2.5.0, v2.5.0-beta1, v2.5.1, 
v2.5.2, v2.5.3] but these conflict with your requirements or 
minimum-stability.
    - Installation request for doctrine/orm ^2.5 -> satisfiable by 
doctrine/orm[v2.5.0, v2.5.1, v2.5.2, v2.5.3, v2.5.4, v2.5.5].


How can I do?

-- 
You received this message because you are subscribed to the Google Groups 
"doctrine-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to doctrine-user+unsubscr...@googlegroups.com.
To post to this group, send email to doctrine-user@googlegroups.com.
Visit this group at https://groups.google.com/group/doctrine-user.
For more options, visit https://groups.google.com/d/optout.

Reply via email to