Hello,

I upgraded from 3.9.3 to 4.0.1 and I had warnings in the webservice Rest explorer (/htdocs/api/admin/explorer.php) and in every webservice call:


Warning: substr() expects parameter 1 to be string, array given in htdocs/includes/restler/framework/Luracast/Re

This is a known issue in Luracast/Restler that has been corrected:
https://github.com/Luracast/Restler/issues/540

I upgraded locally to the latest Luracast/Restler and the warnings disappeared.

The library should be updated in Dolibarr sources.

--
dataetic

*Nicolas Dorigny*
Consultant - Développeur web freelance
n...@dataetic.fr <mailto:n...@dataetic.fr> | 05 61 87 01 89 <tel:0561870189> | 06 65 68 44 64 <tel:0665684464>

_______________________________________________
Dolibarr-dev mailing list
Dolibarr-dev@nongnu.org
https://lists.nongnu.org/mailman/listinfo/dolibarr-dev

Répondre à