On Friday, 9 March 2018 14:36:25 GMT Terry Coles wrote:
> The light at the end of the tunnel is rapidly vanishing.  Having worked
> consistently for many reboots, I just got a couple of occasions when Card 0
> came up as the bcm audio and the TOWER device got moved to Card 2.

I may have made some progress.  I've moved the contents of my .asoundrc file to 
/etc/
asound.conf and I /think/ that I've now got the TOWER and CHANCEL USB devices 
coming 
up as hw:2,0 and hw:1,0 respectively.  Time will tell if they stay there.

I may have made a little progress on the driver thing too, but I don't know 
what it all 
means.

What I am now seeing is somewhat weird. Outside of my Python program I can cd 
to a 
Playlist directory and issue:

        mpg321 -m -a hw:1,0 <filename.mp3>

and it works, playing from the USB device designated CHANCEL. Staying in the 
same 
directory I kill playback of the above file and issue:

        mpg321 -m -a hw:2,0 <the same filename.mp3>

and it now plays from the USB device designated TOWER. If I then kill that 
playback and 
move to the directory which contains the bells and issue:

  mpg321 -m -a hw:2,0 <a bells filename.mp3>

The playback fails with the error:

        can't open libao driver with device hw:0,0 (is device in use?)

as mentioned previously. If I run top, a Zombie mpg321 process shows up.  Any 
ideas as to 
what is going on?


-- 



                Terry Coles
-- 
Next meeting:  Bournemouth, Tuesday, 2018-04-03 20:00
Meets, Mailing list, IRC, LinkedIn, ...  http://dorset.lug.org.uk/
New thread:  mailto:dorset@mailman.lug.org.uk / CHECK IF YOU'RE REPLYING
Reporting bugs well:  http://goo.gl/4Xue     / TO THE LIST OR THE AUTHOR

Reply via email to