On 15/01/2022 12:00, dorset-requ...@mailman.lug.org.uk wrote:
Send dorset mailing list submissions to

To subscribe or unsubscribe via the World Wide Web, visit
or, via email, send a message with subject or body 'help' to

You can reach the person managing the list at

When replying, please edit your Subject line so it is more specific
than "Re: Contents of dorset digest..."

Today's Topics:

    1. Scanning did work and half-hour later didn't? (JD)
    2. Re: Scanning did work and half-hour later didn't? (Terry Coles)
    3. Re: Scanning did work and half-hour later didn't? (PeterMerchant)
    4. Re: Scanning did work and half-hour later didn't? (Tim)


Message: 1
Date: Fri, 14 Jan 2022 15:24:31 +0000
From: JD <john.dub...@hotmail.co.uk>
To: dorset@mailman.lug.org.uk
Subject: [Dorset] Scanning did work and half-hour later didn't?
Content-Type: text/plain; charset=utf-8; format=flowed

I have a Brother laser printer - DCP1612W.? Yesterday I scanned a couple
of photos and saved them as jpg's.? About a half-hour later I got only
an error message each time I ran xsane, and that is still the case.?
Printing continues to work as normal.

Ubuntu 20.04.3
The error message is: "Failed to open device 'brother4:net;dev0':
Invalid argument."

It's configured to connect via WLAN.? The IP address appears in the
router list occasionally but usually not.

After: scanimage -L
I get "device `brother4:net1;dev0' is a Brother *DCP1610W DCP1612W", so
the correct model is known about.

In /etc/sane.d/dll.conf I've put in "" but I can't restart
saned: "saned.service is masked."

When I run the Brother file "brscan4-0.4.10-1.amd64.deb" I find it is
already installed, of course.

On the internet I found reference to the file:
http://www.sane-project.org/sane-backends.html";, this contains? 2
supported Brothers but not mine.

In desperation I pressed the SCAN button on the printer, but no
miracles, just "Check connection".

What did I do in the fateful 30 mins yesterday afternoon!?


I've used Brother printers/MF devices for years and never had a problem with installing software for them. I have occasionally had a "Failed to open...." message like yours. I think I solved it by restarting the (wireless) server it's connected to. Never connected by WLAN though?

 Next meeting: Online, Jitsi, Tuesday, 2022-02-01 20:00
 Check to whom you are replying
 Meetings, mailing list, IRC, ...  http://dorset.lug.org.uk
 New thread, don't hijack:  mailto:dorset@mailman.lug.org.uk

Reply via email to