Those who attended the online meeting on Tuesday will recall my question about accessing the MySQL database at Wimborne Model Town.

To briefly recap, I have been developing a browser based GUI using Flask and (as far as possible) Hamish's Software Framework which manages all the devices within the River System at the site.  These include; Raspberry Pis monitoring water level sensors, Raspberry Pi based Gate Valves, plus pumps and solenoid valves which are managed from adjacent sensor Pis.  Unfortunately, Hamish is out of touch at the moment.

The status of all these devices is written to a MySQL Server running on a recycled D-Link ShareCenter.  Using code copied from the existing framework, I was getting the following when the sockets handler was starting:

    Connection Refused (NAS): [Errno 111]

The suggestion from the Meeting was that this was a sockets error and I should try to access the database independently using the MySQL client from a console.  If this worked, then I should be able to use Python's own database tools under Flask to access the data I wanted.

I tried this, but believe I will have to install a much earlier version of MySQL on PC because the server rejects my queries with:

ERROR 1043 (08S01): Bad handshake

I then tried to ssh into the device using the passwords that I have for admin on both the D-Link and the MySQL server.  Neither worked (permission denied), but I can log in to the D-Link and thence to the PHPMyAdmin App with these credentials through a browser.

I have several passwords for the server; one used in the Software Framework; one for the Browser interface for PHPMyAdmin and one used by Hamish within an earlier GUI which runs on the D-Link.

Any thoughts on what I'm missing?

Terry Coles

 Next meeting: Online, Jitsi, Tuesday, 2023-08-01 20:00
 Check to whom you are replying
 Meetings, mailing list, IRC, ...  http://dorset.lug.org.uk
 New thread, don't hijack:  mailto:dorset@mailman.lug.org.uk

Reply via email to