We are planning to fix this for 2.3.1 release.

---Aki TuomiDovecot oy
-------- Original message --------From: TG Servers <sr...@prvtmail.net> Date: 
14/02/2018  22:10  (GMT+02:00) To: dovecot@dovecot.org Subject: Re: Problem 
with CentOS package for 2.3.0 and old dependency in
  systemd with clean install 
Hi,

are there any news on this?
Or do we have to go the way install old dovecot/remove it or upgrade
instead of clean install?
Because as the ssl-params executaböe is missing in 2.3.0 I don't know
how else I should create it. If this file isn't even needed for 2.3.0
can it be a file with any content eg 'touch
/var/lib/dovecot/ssl-parameters.dat' so that the file is just there and
dovecot-init.servive doesn't want to call the
/usr/libexec/dovecot/ssl-params executable?

Thanks,
Thomas

Am 02.02.2018 um 09:26 schrieb Aki Tuomi:
> 
>> On February 2, 2018 at 5:09 AM TG Servers wrote:
>>
>>
>> Hi,
>>
>> you definitely have a problem with the packages out of your own repo for
>> version 2.3.0 and CentOS.
>> And this is only if you do a clean install, meaning there was no lower
>> dovecot version ever running on the system.
>>
>> If you want to 'systemctl start dovecot' it breaks with a dependency
>> error which comes from dovecot-init.service.
>>
>> dovecot-init.service :
>> [Unit]
>> Description=One-time Dovecot init service
>> ConditionPathExists=|!/var/lib/dovecot/ssl-parameters.dat
>> ConditionPathExists=|!/etc/pki/dovecot/certs/dovecot.pem
>>
>> [Service]
>> Type=oneshot
>> RemainAfterExit=no
>> ExecStart=/bin/sh -c '\
>> if [ ! -f /etc/pki/dovecot/certs/dovecot.pem ]; \
>> then\
>> SSLDIR=/etc/pki/dovecot/
>> OPENSSLCONFIG=/etc/pki/dovecot/dovecot-openssl.cnf
>> /usr/libexec/dovecot/mkcert.sh /dev/null 2>&1;\
>> fi;\
>> if [ ! -f /var/lib/dovecot/ssl-parameters.dat ]; \
>> then\
>> /usr/libexec/dovecot/ssl-params >/dev/null 2>&1; \
>> fi'
>>
>> It wants to call /usr/libexec/dovecot/ssl-params if
>> /var/lib/dovecot/ssl-parameters.dat (which is deprecated now as I
>> understood) is not existing.
>> The problem is in 2.3.0 /usr/libexec/dovecot/ssl-params is not existent
>> anymore.
>>
>> This error does not occur if you for instance install 2.2.x from the
>> base repo, start it once, and then update the version from your repo.
>> This is because the ssl-parameters.dat was created with the old version
>> then.
>>
>> But this should not be the expected behaviour I think. It should be
>> possible to do a fresh install of 2.3.0 on a fresh system.
>>
>> Can you please get back to me on that?
>>
>> Thanks,
>> Thomas
> 
> 
> Thank you for reporting this, we'll look into it.
> 
> ---
> Aki Tuomi
> 
> Dovecot oy
> 

Reply via email to