Hi there,

I am new Saros developer having trouble with the installation. I will
describe the problem I've been having in the hope someone can give me a

OS: Ubuntu 14.04
While following the http://www.saros-project.org/dev-environment-reqs
guide, I downloaded Eclipse Indigo. Saros/E was working after all the
steps. However, whenever I tried to select Windows -> Show View -> Saros
HTML to see the HTML-GUI, the following Error appeared:

# A fatal error has been detected by the Java Runtime Environment:
#  SIGSEGV (0xb) at pc=0x00007f16dae53eaf, pid=20314, tid=139737883174656
# # JRE
version: Java(TM) SE Runtime Environment (7.0_79-b15) (build
# Java VM: Java HotSpot(TM) 64-Bit Server VM (24.79-b02 mixed mode
linux-amd64 compressed oops)
# Problematic frame:
# C  [libgdk-x11-2.0.so.0+0x4ceaf]  gdk_display_open+0x3f #
# Core dump written. Default location: /home/*****/core24342

An Internet search delivered 3 tips:
1. Add -Dorg.eclipse.swt.browser.DefaultType=mozilla at the end of
2. Set amount of processes pro user to unlimited with 'ulimit -c unlimited'

After these 2 did not work, I tried the third one:
3. Upgrade Indigo

Maybe I should've upgraded to Kepler (next one up), but I did to Mars, and
now not even Saros/E will start without throwing the same 'core dump

Has anyone encountered this situation before? If so, any help is very much



Check out the vibrant tech community on one of the world's most 
engaging tech sites, SlashDot.org! http://sdm.link/slashdot
DPP-Devel mailing list

Reply via email to