On 4/23/2018 3:52 PM, Jani Nikula wrote:
On Mon, 23 Apr 2018, "Nautiyal, Ankit K" <ankit.k.nauti...@intel.com> wrote:
On 4/20/2018 7:42 PM, Ville Syrjälä wrote:
On Fri, Apr 20, 2018 at 07:01:47PM +0530, Nautiyal, Ankit K wrote:
From: Ankit Nautiyal <ankit.k.nauti...@intel.com>
+bool
+drm_mode_aspect_ratio_allowed(const struct drm_file *file_priv,
+                             struct drm_mode_modeinfo *umode)
+{
+       return file_priv->aspect_ratio_allowed || (umode->flags &
+               DRM_MODE_FLAG_PIC_AR_MASK) == DRM_MODE_FLAG_PIC_AR_NONE;
Odd line split here. Makes this a bit hard to read.
I would split after the ||
Agreed. I wasn't sure how to let it have better readability and less
than 80 char length at the same time. Will fix this.
80 chars is not a strict requirement. Readability is. ;)

BR,
Jani.

Roger that! :)


_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to