Hi all,

I've a workstation which has internal VGA that is detected as AST 2400 and 
with it EDID has been always quite flaky (except for some time it worked 
with 4.14 long enough that I thought the problems would be past until the 
problems reappeared also with 4.14). Thus, I've provided manually the EDID 
that I extracted from the monitor using other computer (the monitor itself 
worked just fine on the earlier computer so it is likely fine).

I setup the manual EDID using drm_kms_helper.edid_firmware, however,
after upgrading to 4.19.45 it stopped working (no "Got external EDID base 
block" appears in dmesg, the text mode is kept in the lower res mode, and 
Xorg logs no longer dumps the EDID info like it did with 4.14). So I guess 
the EDID I provided manually on the command line is not correctly put into 
use with 4.19+ kernels.

The 4.19 dmesg indicated that drm_kms_helper.edid_firmware is deprecated 
so I also tested with drm.edid_firmware it suggested as the replacement 
but with no luck (but I believe also the drm_kms_helper one should have 
worked as it was only "deprecated").

I also tried 5.1.2 but it did not work any better (and with it also tried 
removing all the manual *.edid_firmware from the command line so I still 
need to provide one manually to have it reliable working it seems).

dri-devel mailing list

Reply via email to