https://bugs.freedesktop.org/show_bug.cgi?id=108718

--- Comment #4 from Pierre-Eric Pelloux-Prayer 
<pierre-eric.pelloux-pra...@amd.com> ---
(In reply to Pierre-Eric Pelloux-Prayer from comment #2)
> Can you still reproduce this issue?
> 
> It seems to work fine here with a recent kernel + mesa configuration.

Correction: I retested and can reproduce the problem partially.

After zooming and scrolling for a while, there are logs like this in dmesg:


[drm:amdgpu_cs_ioctl [amdgpu]] *ERROR* amdgpu_vm_validate_pt_bos() failed.
[drm:amdgpu_cs_ioctl [amdgpu]] *ERROR* Not enough memory for command
submission!
[TTM] Failed to find memory space for buffer 0x00000000de5c5282 eviction
[TTM]  No space for 00000000de5c5282 (2224 pages, 8896K, 8M)
[TTM]    placement[0]=0x00060002 (1)
[TTM]      has_type: 1
[TTM]      use_type: 1
[TTM]      flags: 0x0000000A
[TTM]      gpu_offset: 0x00000000
[TTM]      size: 786432
[TTM]      available_caching: 0x00070000
[TTM]      default_caching: 0x00010000
[TTM]  0x0000000000000400-0x0000000000000401: 1: used
[TTM]  0x0000000000000401-0x0000000000000443: 66: used
[TTM]  0x0000000000000443-0x0000000000000445: 2: used
[TTM]  0x0000000000000445-0x0000000000000447: 2: used
[TTM]  0x0000000000000447-0x0000000000000449: 2: used
[TTM]  0x0000000000000449-0x000000000000044b: 2: used
[TTM]  0x000000000000044b-0x000000000000044d: 2: used
[TTM]  0x000000000000044d-0x000000000000044f: 2: used
[TTM]  0x000000000000044f-0x0000000000000451: 2: used
[TTM]  0x0000000000000451-0x0000000000000453: 2: used
[TTM]  0x0000000000000453-0x0000000000000455: 2: used
[TTM]  0x0000000000000455-0x0000000000000456: 1: used
[TTM]  0x0000000000000456-0x0000000000000556: 256: used
[TTM]  0x0000000000000556-0x0000000000000557: 1: used
[TTM]  0x0000000000000557-0x0000000000000558: 1: used
[TTM]  0x0000000000000558-0x0000000000000559: 1: used
[TTM]  0x0000000000000559-0x000000000000055a: 1: used
[TTM]  0x000000000000055a-0x000000000000055b: 1: used
[TTM]  0x000000000000055b-0x000000000000055c: 1: used
[TTM]  0x000000000000055c-0x000000000000055d: 1: used
[TTM]  0x000000000000055d-0x000000000000055e: 1: used
[TTM]  0x000000000000055e-0x0000000000000560: 2: used
[TTM]  0x0000000000000560-0x0000000000000561: 1: used
[TTM]  0x0000000000000561-0x0000000000000562: 1: used
[TTM]  0x0000000000000562-0x0000000000000563: 1: used
[TTM]  0x0000000000000563-0x0000000000000565: 2: used
[TTM]  0x0000000000000565-0x0000000000000665: 256: used
[TTM]  0x0000000000000665-0x000000000000075c: 247: used
[TTM]  0x000000000000075c-0x0000000000000800: 164: free
[TTM]  0x0000000000000800-0x0000000000000900: 256: used
[TTM]  0x0000000000000900-0x0000000000000cca: 970: used
[TTM]  0x0000000000000cca-0x0000000000040000: 258870: free
[TTM]  total: 261120, used 2086 free 259034


The computer doesn't hang or crash though and if I close Firefox's window
everything goes back to normal.

(using: Mesa master, LLVM 10, kernel 865b4ca43816 from amd-staging-drm-next)

-- 
You are receiving this mail because:
You are the assignee for the bug.
_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to