Replace open coded divisor calculations with the DIV_ROUND_UP kernel
macro for better readability.
Issue found using coccinelle:
@@
expression n,d;
@@
(
- ((n + d - 1) / d)
+ DIV_ROUND_UP(n,d)
|
- ((n + (d - 1)) / d)
+ DIV_ROUND_UP(n,d)
)

Signed-off-by: Wambui Karuga <wambui.karu...@gmail.com>
---
 drivers/gpu/drm/drm_agpsupport.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/drm_agpsupport.c b/drivers/gpu/drm/drm_agpsupport.c
index 6e09f27fd9d6..4c7ad46fdd21 100644
--- a/drivers/gpu/drm/drm_agpsupport.c
+++ b/drivers/gpu/drm/drm_agpsupport.c
@@ -212,7 +212,7 @@ int drm_agp_alloc(struct drm_device *dev, struct 
drm_agp_buffer *request)
        if (!entry)
                return -ENOMEM;
 
-       pages = (request->size + PAGE_SIZE - 1) / PAGE_SIZE;
+       pages = DIV_ROUND_UP(request->size, PAGE_SIZE);
        type = (u32) request->type;
        memory = agp_allocate_memory(dev->agp->bridge, pages, type);
        if (!memory) {
@@ -325,7 +325,7 @@ int drm_agp_bind(struct drm_device *dev, struct 
drm_agp_binding *request)
        entry = drm_agp_lookup_entry(dev, request->handle);
        if (!entry || entry->bound)
                return -EINVAL;
-       page = (request->offset + PAGE_SIZE - 1) / PAGE_SIZE;
+       page = DIV_ROUND_UP(request->offset, PAGE_SIZE);
        retcode = drm_bind_agp(entry->memory, page);
        if (retcode)
                return retcode;
-- 
2.23.0

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to