This is really a cosmetic change just to make a bit more readable the
code after convert the driver to drm_bridge. The bridge variable name
will be used by the encoder drm_bridge, and the chained bridge will be
named next_bridge.

Signed-off-by: Enric Balletbo i Serra <enric.balle...@collabora.com>
---

Changes in v2: None

 drivers/gpu/drm/mediatek/mtk_dsi.c | 9 +++++----
 1 file changed, 5 insertions(+), 4 deletions(-)

diff --git a/drivers/gpu/drm/mediatek/mtk_dsi.c 
b/drivers/gpu/drm/mediatek/mtk_dsi.c
index cfa45d6abd74..44ee884cc31c 100644
--- a/drivers/gpu/drm/mediatek/mtk_dsi.c
+++ b/drivers/gpu/drm/mediatek/mtk_dsi.c
@@ -182,7 +182,7 @@ struct mtk_dsi {
        struct drm_encoder encoder;
        struct drm_connector conn;
        struct drm_panel *panel;
-       struct drm_bridge *bridge;
+       struct drm_bridge *next_bridge;
        struct phy *phy;
 
        void __iomem *regs;
@@ -903,8 +903,9 @@ static int mtk_dsi_create_conn_enc(struct drm_device *drm, 
struct mtk_dsi *dsi)
        dsi->encoder.possible_crtcs = 1;
 
        /* If there's a bridge, attach to it and let it create the connector */
-       if (dsi->bridge) {
-               ret = drm_bridge_attach(&dsi->encoder, dsi->bridge, NULL, 0);
+       if (dsi->next_bridge) {
+               ret = drm_bridge_attach(&dsi->encoder, dsi->next_bridge, NULL,
+                                       0);
                if (ret) {
                        DRM_ERROR("Failed to attach bridge to drm\n");
                        goto err_encoder_cleanup;
@@ -1185,7 +1186,7 @@ static int mtk_dsi_probe(struct platform_device *pdev)
        }
 
        ret = drm_of_find_panel_or_bridge(dev->of_node, 0, 0,
-                                         &dsi->panel, &dsi->bridge);
+                                         &dsi->panel, &dsi->next_bridge);
        if (ret)
                goto err_unregister_host;
 
-- 
2.25.1

_______________________________________________
dri-devel mailing list
dri-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/dri-devel

Reply via email to