Use channel class definitions instead of magic numbers.

Signed-off-by: Danilo Krummrich <d...@redhat.com>
---
 drivers/gpu/drm/nouveau/nouveau_chan.c | 8 +++++---
 1 file changed, 5 insertions(+), 3 deletions(-)

diff --git a/drivers/gpu/drm/nouveau/nouveau_chan.c 
b/drivers/gpu/drm/nouveau/nouveau_chan.c
index dffbee59be6a..ac56f4689ee3 100644
--- a/drivers/gpu/drm/nouveau/nouveau_chan.c
+++ b/drivers/gpu/drm/nouveau/nouveau_chan.c
@@ -442,9 +442,11 @@ nouveau_channel_init(struct nouveau_channel *chan, u32 
vram, u32 gart)
        }
 
        /* initialise dma tracking parameters */
-       switch (chan->user.oclass & 0x00ff) {
-       case 0x006b:
-       case 0x006e:
+       switch (chan->user.oclass) {
+       case NV03_CHANNEL_DMA:
+       case NV10_CHANNEL_DMA:
+       case NV17_CHANNEL_DMA:
+       case NV40_CHANNEL_DMA:
                chan->user_put = 0x40;
                chan->user_get = 0x44;
                chan->dma.max = (0x10000 / 4) - 2;
-- 
2.41.0

Reply via email to