Replace the direct use of magic number '0' with the DRM_FORCE_UNSPECIFIED
macro to improve code readability.

Signed-off-by: hongao <hon...@uniontech.com>

diff --git a/drivers/gpu/drm/drm_sysfs.c b/drivers/gpu/drm/drm_sysfs.c
index 60c1f26edb6f..e9e67ef0904d 100644
--- a/drivers/gpu/drm/drm_sysfs.c
+++ b/drivers/gpu/drm/drm_sysfs.c
@@ -198,7 +198,7 @@ static ssize_t status_store(struct device *device,
        old_force = connector->force;
 
        if (sysfs_streq(buf, "detect"))
-               connector->force = 0;
+               connector->force = DRM_FORCE_UNSPECIFIED;
        else if (sysfs_streq(buf, "on"))
                connector->force = DRM_FORCE_ON;
        else if (sysfs_streq(buf, "on-digital"))
-- 
2.33.1

Reply via email to