It seems a bit arbitrary, like we open-code this (at risk of making a mistake)
in some places but not others.
[...]
One could argue that maybe one would want a order_to_pages() helper (that
could use BIT() internally), but I am certainly not someone that would
suggest that at this point ... :)
I mean maybe.
Anyway as I said none of this is massively important, the open-coding here is
correct, just seems silly.
Maybe we really want a ORDER_PAGES() and PAGES_ORDER().
But I mean, we also have PHYS_PFN() PFN_PHYS() and see how many "<<
PAGE_SIZE" etc we are using all over the place.
+
/*
* compound_nr() returns the number of pages in this potentially compound
* page. compound_nr() can be called on a tail page, and is defined to
diff --git a/mm/page_alloc.c b/mm/page_alloc.c
index baead29b3e67b..426bc404b80cc 100644
--- a/mm/page_alloc.c
+++ b/mm/page_alloc.c
@@ -6833,6 +6833,7 @@ static int __alloc_contig_verify_gfp_mask(gfp_t gfp_mask,
gfp_t *gfp_cc_mask)
int alloc_contig_range_noprof(unsigned long start, unsigned long end,
acr_flags_t alloc_flags, gfp_t gfp_mask)
Funny btw th
{
+ const unsigned int order = ilog2(end - start);
unsigned long outer_start, outer_end;
int ret = 0;
@@ -6850,6 +6851,9 @@ int alloc_contig_range_noprof(unsigned long start,
unsigned long end,
PB_ISOLATE_MODE_CMA_ALLOC :
PB_ISOLATE_MODE_OTHER;
+ if (WARN_ON_ONCE((gfp_mask & __GFP_COMP) && order > MAX_FOLIO_ORDER))
+ return -EINVAL;
Possibly not worth it for a one off, but be nice to have this as a helper
function, like:
static bool is_valid_order(gfp_t gfp_mask, unsigned int order)
{
return !(gfp_mask & __GFP_COMP) || order <= MAX_FOLIO_ORDER;
}
Then makes this:
if (WARN_ON_ONCE(!is_valid_order(gfp_mask, order)))
return -EINVAL;
Kinda self-documenting!
I don't like it -- especially forwarding __GFP_COMP.
is_valid_folio_order() to wrap the order check? Also not sure.
OK, it's not a big deal.
Can we have a comment explaining this though? As people might be confused
as to why we check this here and not elsewhere.
I can add a comment.
--
Cheers
David / dhildenb