This series addresses a shortcoming whereby a hot plug event is sent without it being passed the actual connector that caused it. This takes into consideration both the polling path and the HPD (Hot Plug Detect) path.
The motivation is that user-space applications such as Weston would previously receive non-connector-specific hotplug events, and then have to figure out themselves which connector needs to have a modeset executed on. This notably did not work when the hotplug events came in too fast, resulting in Weston missing an on-off-on transition of a connector, seeing that its state was unchanged from "on" so can't be the one that was hotplugged, and skipping reinitialising it as it looks through the other connectors that could've caused it. The real world implication is that on setups with slightly sketchy HDMI connections, a brief flicker in the HPD signal could result in video output bidding farewell entirely until a manual proper re-plug was performed. By sending connector specific hotplug events, this ambiguity is resolved without any change to the user-space API. Future work should however make the kernel explicitly request a modeset from userspace through a more robust path, either by using link-status (nb. the userspace side may not handle it properly at present) or by exposing the epoch counter through the uAPI such that fragile state comparison code is no longer needed. This change results in potentially more hotplug events being sent than previously, as n changed connectors at a time result in n hotplug events, rather than just a single one. Signed-off-by: Nicolas Frattaroli <[email protected]> --- Changes in v10: - Fix delayed_event processing in !drm_kms_helper_poll path. This necessitates taking the lock in that path for reading delayed_event as well. I chose not to transition delayed_event to an atomic_t yet, as I don't want to rock the boat too much in this series. - Move delayed_event read/clear inside of the mode_config.mutex locked section. - Link to v9: https://patch.msgid.link/[email protected] Changes in v9: - Get rid of the kmalloc_array by splitting the hotplug event into its two constituent parts to avoid the deadlock. - Link to v8: https://patch.msgid.link/[email protected] Changes in v8: - Drop pending_hp patch - Add patch correcting epoch_counter documentation - Rework implementation such that hotplug events are still sent outside the mode_config mutex, but don't iterate through the connector list without the lock. - Link to v7: https://patch.msgid.link/[email protected] Changes in v7 RESEND: - None, other than removing the leftover diffstat from the cover letter - Link to v7: https://lore.kernel.org/r/[email protected] Changes in v7: - Drop the two vkms patches, as I don't want them to be blocked on review. I still think they're correct, but they're not essential and don't need to block this series. - Link to v6: https://lore.kernel.org/r/[email protected] Changes in v6: - Rewrote cover letter to explain the motivation for this series more plainly - Rename "status_changed" to "pending_hp" - Set "pending_hp" in the existing path that would also affect epoch_counter - No longer set the boolean in drm_helper_probe_single_connector_modes, as it does not appear to be necessary - Reword commits to better justify the changes - Link to v5: https://lore.kernel.org/r/[email protected]/ Changes in v5: - vkms: add support for sending the CONNECTOR ID when hot-plugging through ConfigFS - as reported by Louis, vkms can now make use of ConfigFS to simulate connector status. - vkms: add a small change to ignore previous/old drm connector status when sending out hot-plug uevent. - Link to v4: https://lore.kernel.org/r/[email protected]/ Changes in v4: - removed the "This patch" bit - Dmitry - added a short note when the flag is set and cleared - Dmitry - address double dead-locking detected - kbot: https://lore.kernel.org/dri-devel/[email protected]/ - virtual connectors do not seem have any kind of hotplug - added polling in vkms - as noted by Ian - Link to v3: https://lore.kernel.org/r/[email protected]/ Changes in v3: - Address comments from Dmitry: - guard connector status write with mode_config.mutex - avoid setting up the connector status and immediately unset it. Do the unset in drm_kms_helper_hotplug_event/drm_kms_helper_connector_hotplug_event - Link to v2: https://lore.kernel.org/r/[email protected]/ Changes in v2: - Address comments from Daniel: - split patch into 2, one that introduces a bool to track connector connection status change and a patch that uses that to be able to send hot plug events with the proper CONNECTOR ID to udev and further pass that down to user-space - nuke out mutex when iterating connector list - fix typo - Link to v1: https://lore.kernel.org/r/[email protected]/ --- Nicolas Frattaroli (2): drm/connector: Fix epoch_counter docs to reflect reality drm: Send per-connector hotplug events drivers/gpu/drm/drm_probe_helper.c | 53 ++++++++++++++++++++------------------ include/drm/drm_connector.h | 5 +++- 2 files changed, 32 insertions(+), 26 deletions(-) --- base-commit: 5fb5a9a63cf5ece68e0eeb6fa397da27712bccf0 change-id: 20260121-hot-plug-passup-f8ed03f7c202 Best regards, -- Nicolas Frattaroli <[email protected]>
