Alberto Ruiz via B4 Relay <[email protected]> writes:

Hello Alberto,

Thanks for the patches. Nice cleanup!

> The ssd130x_init(), ssd132x_init(), and ssd133x_init() functions each
> issue long chains of individual ssd130x_write_cmd() calls, each
> followed by its own error check.  This is verbose and makes the init
> sequences harder to read and maintain.
>
> This series introduces ssd130x_run_cmd_seq(), which interprets a flat
> byte array of length-prefixed command entries terminated by a zero
> byte, and converts the three init functions to use it.  The result is
> a net reduction of ~110 lines, with the hardware programming sequences
> now expressed as compact, declarative tables rather than imperative
> call-and-check chains.
>
> Signed-off-by: Alberto Ruiz <[email protected]>
> ---
> Alberto Ruiz (4):
>       drm/solomon: add ssd130x_run_cmd_seq() for batch command execution
>       drm/solomon: use ssd130x_run_cmd_seq() in ssd130x_init()
>       drm/solomon: use ssd130x_run_cmd_seq() in ssd132x_init()
>       drm/solomon: use ssd130x_run_cmd_seq() in ssd133x_init()

For all the patches:

Reviewed-by: Javier Martinez Canillas <[email protected]>
Tested-by: Javier Martinez Canillas <[email protected]>

I'll wait for a few days to merge them, in case someone else have comments.

-- 
Best regards,

Javier Martinez Canillas
Core Platforms
Red Hat

Reply via email to